bloody ticking sound
  • Help
Results 1 to 5 of 5
  1. #1
    Fellow Frogger!
    Join Date
    Feb 2001
    Location
    Sydney
    Posts
    493

    bloody ticking sound

    My 306's indicator doesn't stop ticking! well the actual blinking stops after the indicator lever returns to the neutral position but the ticking sound still continues. It actually speeds up, ticks faster! I haven't read about this problem before but has anyone else? I haven't had a chance to pull apart the plastic around the steering column to check if anything looks out of place. Any advice is appreciated


    Advertisement

  2. #2
    Local Tyrant gibgib's Avatar
    Join Date
    Mar 2000
    Location
    Sunshine Coast, Queensland
    Posts
    3,532
    Our 405 does this, usually at night, ie. with lights on. Whenever I go to investigate, it never plays up so I've learnt to live with it.
    It does seem to be the blinker relay under the steering column....
    Would like to know how to fix this as well!

  3. #3
    Member
    Join Date
    Jan 2001
    Location
    Adelaide SA
    Posts
    32
    have come across this on several 306's ,faulty indicator switch which is a sealed unit.fit new switch .
    <font face="Verdana, Arial" size="2">Originally posted by Pugsly:
    My 306's indicator doesn't stop ticking! well the actual blinking stops after the indicator lever returns to the neutral position but the ticking sound still continues. It actually speeds up, ticks faster! I haven't read about this problem before but has anyone else? I haven't had a chance to pull apart the plastic around the steering column to check if anything looks out of place. Any advice is appreciated

  4. #4
    Fellow Frogger!
    Join Date
    Mar 2001
    Location
    Brisbane, QLD, Australia
    Posts
    396
    Mine will click "double time" when I dont fully click the indicator on when changing lanes etc, but when fully locked in to indicator mode, it behaves normally.

    Go figure.....

  5. #5
    Tadpole
    Join Date
    Apr 2001
    Location
    Trinidad
    Posts
    1
    This problem is caused by the indicator switch itself. If you open the switch you will find some springs and some contacts. Clean the contacts and the problem will stop, if not replace the switch. We do about 10 a month of these.

    Ryan


    <font face="Verdana, Arial" size="2">Originally posted by Pugsly:
    My 306's indicator doesn't stop ticking! well the actual blinking stops after the indicator lever returns to the neutral position but the ticking sound still continues. It actually speeds up, ticks faster! I haven't read about this problem before but has anyone else? I haven't had a chance to pull apart the plastic around the steering column to check if anything looks out of place. Any advice is appreciated

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •