505 sti fuel pump
  • Register
  • Help
Results 1 to 4 of 4
  1. #1
    Tadpole
    Join Date
    Jun 2004
    Location
    melbourne
    Posts
    8

    Default 505 sti fuel pump

    having problems with the electrical connections to the fuel pump

    fuel pump runs fine

    however keeps going dead after a few weeks

    Advertisement


    when you play around or move the connectors fuel pump works again

    anyone know if you can improve the connections ( seems the plastic housing
    is the problem and prevents the connector from making a proper connection some of time

    i dont see the need to replace the fuel pump

    alanh

  2. #2
    Fellow Frogger! PCOATES505's Avatar
    Join Date
    Jun 2002
    Location
    Gunbower
    Posts
    384

    Default

    Quote Originally Posted by alanh
    having problems with the electrical connections to the fuel pump

    fuel pump runs fine

    however keeps going dead after a few weeks

    when you play around or move the connectors fuel pump works again

    anyone know if you can improve the connections ( seems the plastic housing
    is the problem and prevents the connector from making a proper connection some of time

    i dont see the need to replace the fuel pump

    alanh
    What connectors are you talking about? All the sti's I have seen have bolt on connections at the pump. It could be the tachometric relay playing up!!
    Regards Pete

    I am gunna get another 403 on the road........one day

  3. #3
    Fellow Frogger!
    Join Date
    Jul 2001
    Location
    south australia
    Posts
    225

    Default

    some times the terminals on the end of the wires dont sit into the post guided properly,its the plastic raised sleeve.take the terminals off and check if the wires are crimped in tightly to the terminals,a lot i see have been recrimped and work loose.make sure the terminals fit down into the recess and do up properly.you may have a sticking pump and by tapping it you a dislodging the impellor and goes for a while,this is not uncommon in old pumps.

  4. #4
    Fellow Frogger! pips's Avatar
    Join Date
    Dec 2004
    Location
    Behind you
    Posts
    487

    Default

    Crimping is for loosers. Solder everything!!!
    Ever wonder why Mad Scientist talk to themselves? They know others just wouldn't understand.

    The software said "Windows 98 or better". So I installed Linux.

    1990 405 Mi16

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •