Leaking Injectors - 205
  • Register
  • Help
Results 1 to 2 of 2
  1. #1
    VIP Sponsor
    Join Date
    Aug 2000
    Posts
    9,180

    Default Leaking Injectors - 205

    I got the 205 GTI running on the Megasquirt today.
    I had the tachymetric relay bridged out whilst I was setting up the parameters in the ECU. On going to start it the engine wouldn't turn over, two of the cylinders were full of petrol!
    Looks like new injectors needed.
    I had this problem after the Deni autocross a few weeks back and thought it might have been water leaking past the head gasket. It had given no trouble since then but I have been dreading having to fix it.
    I'm a bit happier about changing injectors than doing a head gasket change.
    Graham

    Advertisement

  2. #2
    Fellow Frogger! jarrods's Avatar
    Join Date
    Mar 2004
    Location
    Melbourne
    Posts
    303

    Default

    Quote Originally Posted by GRAHAM WALLIS
    I got the 205 GTI running on the Megasquirt today.
    I had the tachymetric relay bridged out whilst I was setting up the parameters in the ECU. On going to start it the engine wouldn't turn over, two of the cylinders were full of petrol!
    Looks like new injectors needed.
    I had this problem after the Deni autocross a few weeks back and thought it might have been water leaking past the head gasket. It had given no trouble since then but I have been dreading having to fix it.
    I'm a bit happier about changing injectors than doing a head gasket change.
    Graham
    Did you actually get it running, if so how well. Is it an improvement over the Bosch setup?

    Jarrod

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •