Gremlins in the 205
  • Register
  • Help
Results 1 to 4 of 4
  1. #1
    Member burkey's Avatar
    Join Date
    Mar 2005
    Location
    Sydney
    Posts
    57

    Default Gremlins in the 205

    Gizmo and his fury friends are at it again.....

    Advertisement


    Ive got troubles with my indicators, they are working for like three or four blinks then stop. No sound from the glove box when this happens. They start up again if i turn off the indicator and back on again.

    Has anyone else had this problem, and how easy was it to fix and a cost. It is a 205SI 1992.

    I'm just waiting to get pulled over and or rear ended


    Thanks in advance


    Burkey.

  2. #2
    Member burkey's Avatar
    Join Date
    Mar 2005
    Location
    Sydney
    Posts
    57

    Default

    anyone???

  3. #3
    Fellow Frogger! Wintermute's Avatar
    Join Date
    Apr 2005
    Location
    Sydney
    Posts
    863

    Default

    Quote Originally Posted by burkey
    anyone???
    just a guess, but could be the flasher unit. Maybe the bi metal strip (assuming it isn't electronic) stops working after a few blinks due to heat??? can't imagine a flasher unit being real expensive, probably under $20, and should just be a case of pull out the old one, and plug in the new one..... not sure but I'd guess it is in the fuse/relay box, in the top back of the glove box...

    Tony.
    306 S16 1995 black
    Morris 1100 1965 green

  4. #4
    Member plasmapug's Avatar
    Join Date
    Mar 2004
    Location
    Canberra
    Posts
    58

    Default

    This probably isn't the solution to your problem, but good to note anyway.....

    My indicators used to bugger up every now and again and you'd hear a sound from the relay. Sometimes they wouldn't come on at all. The culprit? My hazard light switch. When the switch was on, the hazard lights would work fine, but when off, the indicators played up. The hazard switch disconnects the indicator circuit when on so when it failed, it left the indicator circuit open.

    Pete
    ------------------------------
    '88 205GTi

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •