Urgent help please...Xsara race car
  • Register
  • Help
Results 1 to 13 of 13
  1. #1
    Member
    Join Date
    Dec 2004
    Location
    Sydney
    Posts
    34

    Default Urgent help please...Xsara race car

    We did some engine work on the Xsara before Mallala this weekend. After hooking everything up, the engine runs fine until it gets hot & cuts out. Then after a while it starts again???

    My team are travelling to SA tonight from Sydney. If anyone has any answers to this can you please call Garry on 0407 272 165, or if you live in SA & can come to the track and take a look at it, they will be there at around midday Friday. We will give anyone free tickets & lunch for the weekend it you can come out & help.

    Thanks

    Brendon Cook
    0409 952905

    Advertisement

  2. #2
    1000+ Posts alan moore's Avatar
    Join Date
    Oct 2001
    Location
    Ipswich, Queensland.
    Posts
    1,891

    Default

    Try the coil, or perhaps the ignition pickup. When it happens, spray some water on the pickup to cool it and see if it comes good.
    '56 Renault 750 (16TS Power)
    '62 Renault Dauphine Gordini
    '89 Renault Alpine GTA V6 Turbo
    '08 Renault Megane sedan

  3. #3
    Member
    Join Date
    Dec 2004
    Location
    Sydney
    Posts
    34

    Default

    Quote Originally Posted by alan moore
    Try the coil, or perhaps the ignition pickup. When it happens, spray some water on the pickup to cool it and see if it comes good.
    Didnt work, anything else?

  4. #4
    1000+ Posts U Turn's Avatar
    Join Date
    Jan 2004
    Location
    Adelaide
    Posts
    1,761

    Default

    Malalla right? What time on the weekend will you be out there?
    Take the long way home....

    - 306 gti6

  5. #5
    1000+ Posts edgedweller's Avatar
    Join Date
    Jul 2004
    Location
    CLARE SA
    Posts
    2,324

    Default

    That would read "midday friday" ie NOW!!!!!!!!!!!!!!!!!

    ed ge

    Raceday sunday ie ALL WEEKEND!!!!!!!!!!!!!!!!!

  6. #6
    Member
    Join Date
    Dec 2004
    Location
    Sydney
    Posts
    34

    Default

    Hot laps Friday & racing Sat & Sunday.

    Car is at Prestige Formula in Adelaide getting fixed. Like to thank Danny for helping out.

    Brendon.

  7. #7
    Fellow Frogger!
    Join Date
    Sep 2003
    Location
    Adelaide
    Posts
    409

    Default

    Jude, Leigh, Mike etc are any of you thinking of heading on out. I wouldnt mind having a look at Brendans car - and seeing what times it does compared to my frog-stock vehicle.

    I wouldn't mind getting a photo taken of my car next to his - but time constraints probably wont permit.

    SMS me i you want to come (and if you need a lift)

    I wonder what time it starts ? 10:00 am like all Mallala events ?

    '04 Citroen Xsara VTS

    Mallala - 1:29.96

  8. #8
    Member
    Join Date
    Dec 2004
    Location
    Sydney
    Posts
    34

    Default

    Sure thing guys, Garry is my head spanner man, Dane Rudolph my driver should be lurking around there as well. Ask for one of them.

    Please give Garry a call 0407 272 165, he's very keen to speak to you.

    Brendon.
    Last edited by bjcook; 16th April 2005 at 09:09 AM.

  9. #9
    Member
    Join Date
    Dec 2004
    Location
    Sydney
    Posts
    34

    Default

    Thanks to everyone who helped us try to race this weekend. From Prestige Formula in Adelaide & Martin Bray to Citroen owners phoning with helpful tips. It looks like we have had an ECU problem. So back on the truck & back to Sydney.

    Hope to be back on the track for the 3rd round in Brisbane in July.

    Brendon.

  10. #10
    Moderator Alan S's Avatar
    Join Date
    Mar 2001
    Location
    Queensland, Australia
    Posts
    8,923

    Default

    Are you running a standard ECU or are you allowed to run MoTeC or similar?


    Alan S
    If it ain't broke, use a 12" shifter.....that usually does the trick!!

  11. #11
    Member
    Join Date
    Dec 2004
    Location
    Sydney
    Posts
    34

    Default

    Running a unichip at moment. Motec too expensive.

  12. #12
    Fellow Frogger!
    Join Date
    Sep 2003
    Location
    Adelaide
    Posts
    409

    Default

    haha too expensive... i priced a Magneti Marrelli system to replace the standard 1AP.10 or whatever we've got. I wanted an ECU that could do two injectors per cylinder at varying durations. Um "several" thousand without the integrated data logger... no thanks

    '04 Citroen Xsara VTS

    Mallala - 1:29.96

  13. #13
    1000+ Posts PeterT's Avatar
    Join Date
    Jul 2000
    Location
    Castle Hill, Sydney
    Posts
    7,446

    Default

    Quote Originally Posted by bjcook
    Running a unichip at moment. Motec too expensive.

    .........mmmm. You might still be running?

    '92 205 Mi16
    '90 Mi16x4

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •