Constant Dim Charge Light.
  • Register
  • Help
Results 1 to 5 of 5
  1. #1
    1000+ Posts HONG KONG PUGGY's Avatar
    Join Date
    Nov 2002
    Location
    Yarrabilba, Queensland
    Posts
    2,755

    Default Constant Dim Charge Light.

    I noticed tonight, the charge light is not going completely out in our 505 as I started it in the dark in the garage. I can just see the outline of the little battery symbol glowing at idle. I wouldn't have even seen it in the daytime.
    Bosch 55amp alternator,
    Appears to be charging, the volts rise to 14+ when car is running. High beam cuts the revs a little at idle just as lways, so everything appears to be normal.
    Indicator lights bring on the charge light to a brighter glow than the headlights alone do.
    Battery vgc, just new 2 mths.
    Belt tight and not slipping.

    Are the brushes on the way out?

    Chris L.

    Advertisement

  2. #2
    Budding Architect ???? pugrambo's Avatar
    Join Date
    Jul 2000
    Location
    Parkes - N.S.W - Australia - Earth
    Posts
    12,256

    Default

    just check to make sure all the wires have a good contact first but normally the dim glow will get brighter as the brushes wear out in the alternator
    3 x '78 604 SL

    1 x '98 306 GTi6

    1 x secret project

    1 x '98 406 STDT troop carrier and i don't care if it stinks, i don't sniff it's arse Death by wank tank

    1 x '99 406SV 5spd wagon, time to burn more fuel

    1 x 1994 605 SV3.0


    WTD long range fuel tank for 605

  3. #3
    1000+ Posts HONG KONG PUGGY's Avatar
    Join Date
    Nov 2002
    Location
    Yarrabilba, Queensland
    Posts
    2,755

    Default

    Quote Originally Posted by pugrambo
    just check to make sure all the wires have a good contact first but normally the dim glow will get brighter as the brushes wear out in the alternator
    thanx pugrambo.......forgot to mention I removed all wires , cleaned them, tightened the warning light spade lug too... and reattached.
    I'll get the brushes this week and change asap....should probably have a new set here anyway, same bosch alt' as some Renaullts.
    Cheers, Chris and ty again.

  4. #4
    Gone Fishin' Ray Bell's Avatar
    Join Date
    Jun 2001
    Location
    Burpengary and Murrumburrah, Qld and NSW
    Posts
    9,223

    Default

    Maybe there's no rush... mine did it with new brushes anyway... it's been like that for several months, maybe 60,000kms.

  5. #5
    Budding Architect ???? pugrambo's Avatar
    Join Date
    Jul 2000
    Location
    Parkes - N.S.W - Australia - Earth
    Posts
    12,256

    Default

    if the slip rings on the armarture are worn then new brushes will give you the same effect
    3 x '78 604 SL

    1 x '98 306 GTi6

    1 x secret project

    1 x '98 406 STDT troop carrier and i don't care if it stinks, i don't sniff it's arse Death by wank tank

    1 x '99 406SV 5spd wagon, time to burn more fuel

    1 x 1994 605 SV3.0


    WTD long range fuel tank for 605

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •