URGENT help
  • Register
  • Help
Results 1 to 8 of 8

Thread: URGENT help

  1. #1
    Member
    Join Date
    Sep 2003
    Location
    Sydney
    Posts
    116

    Default URGENT help...again!!!

    Hey guys, whilst drving tonight in my Xsara, the engine warngin light came on, then as I slowed down the accelerator stoped working so I turned the car off and on again and its been working since, about 30mins of drving. Ive looked in the manual and it says a problem with the emmissions, cat or ignition...anyone have a clue??

    Advertisement


    Is it alright if I take it to a citroen dealer that Ive never been to??? Really worried about this as I have to drive to uni in Parramatta in peak hour tomorrow morning, its bout 40 min drive as well....
    Last edited by Xsara VTR; 17th September 2004 at 09:16 PM.
    WRC CHAMPS 04!!


  2. #2
    Member
    Join Date
    Sep 2003
    Location
    Sydney
    Posts
    116

    Default

    thanks for your help guys, its all good now, for now I hope...
    WRC CHAMPS 04!!


  3. #3
    1000+ Posts TroyO's Avatar
    Join Date
    Sep 2002
    Location
    Perth, Western Australia
    Posts
    2,511

    Default

    Quote Originally Posted by Xsara VTR
    Hey guys, whilst drving tonight in my Xsara, the engine warngin light came on, then as I slowed down the accelerator stoped working so I turned the car off and on again and its been working since, about 30mins of drving. Ive looked in the manual and it says a problem with the emmissions, cat or ignition...anyone have a clue??
    I had the engine light come up on my car a few times, with "Anti Pollution Fault" shown on the multifunction display. It was totally random, but fortunately didn't affect the operation of the car. In the end, the dealer replaced one of the oxygen sensors. It could be something as simple as an intermittant reading on one of oxygen sensors, or it could be any of the above. Best take it to a Citroen dealer to check it out, especially if you find that the accelerator stopped working. I suppose any Citroen dealer should be fine, unless there are any dealerships in NSW that any of you guys reckon should be avoided?

    Troy.

  4. #4
    Member
    Join Date
    Sep 2003
    Location
    Sydney
    Posts
    116

    Default

    Same problem happened on Wednesday, so i took it to Continental Cars on Thursday morning. spent 2 hours there while they uploaded new stuff to the computer, and did sum other stuff. The car was working fine before I took it in and then after tehy poked around, its not revving past 3 grand so they said to keep it overnight and gave me a BX, what a shocker, lol.... But I got it back today with teh car in even worse shape than it was before, they cant figure the problem out an its not revving past 3000rev. They are Citroen specialsts and cant even work out the problem, he said that they will have to call france and ask them.......

    I am not really happy with the service now that the car is out of warranty and the car is even worse after tehy have messed around with it.....


    can anyone give me an idea what is wrong, im thinking its something to do with the computer after tehy have touched it.....they checked all the sensors and all is well with them....

    cheers
    WRC CHAMPS 04!!


  5. #5
    Moderator Alan S's Avatar
    Join Date
    Mar 2001
    Location
    Queensland, Australia
    Posts
    8,923

    Default

    Don't panic mate; it's a case of "You stuffed it so you'd better fix it!!" as far as Buntings are concerned.
    Unfortunately, you did what most owners do when the dreaded light comes on...................PANIC!!!!!!!!! which is quite understandable, but remember, if the light comes on, it doesn't mean the computers stuffed; it means there's been a malfunction. Mine often comes on due to the voltage being drawn down by the starter motor. "Slack arse Al" hasn't got around to sorting the starter motor, so all I do is let it run for a while, switch off and restart and problem gone.
    I can't speak for a Xsara but on a BX there's a pin out test for faults that has been posted in common problems and fixes on this board and from it the cause can be pin pointed.
    Take a look there & see if that's any help. If not just give Mr B a kick in the coight and tell him to undo what he did so you're at least back to square one.

    Alan S
    If it ain't broke, use a 12" shifter.....that usually does the trick!!

  6. #6
    Fellow Frogger! sproose16v's Avatar
    Join Date
    Mar 2004
    Location
    Sydney
    Posts
    263

    Default

    Quote Originally Posted by Xsara VTR
    and gave me a BX, what a shocker, lol....
    Mate dont be gettn like that about a BX! Im sure it wasnt a 16Valve thats why you didnt like it!
    1989 BX 16 Valve Mk1 - SOLD (And Missed)
    http://www.bx16v.cjb.net
    1992 R32 GTSt Skyline

  7. #7
    Fellow Frogger! Janek's Avatar
    Join Date
    May 2004
    Location
    Sydernee
    Posts
    200

    Default

    ive heard that a few times about those cars... seems to be a computer fault more often that any other hasrdware fault... odd

  8. #8
    1000+ Posts bowie's Avatar
    Join Date
    Aug 2002
    Location
    Sydney, Concord City, Sir.
    Posts
    3,373

    Default

    computers. .ekk..


    would have that problem if it was a K-tonricly injected system.

    Works: 2003 YV Commodore (That is Cecil to you)
    Playing: R12, SuperPos, thinks It's a race car and Sunny the R12 Lego set.
    Previous: SuperGrumpy fuel spitting 504ti(ish), SuperComfortable 505 STI, SuperDoper carried my groceries Mi16, Choo Choo'd Volvo S40
    Wanted Will hoard 12/15/17 Junk.

    "More and more of less and less" - Marina Abramović

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •