Jaeger 504 fuel sender fixed
  • Register
  • Help
Results 1 to 2 of 2
Like Tree1Likes
  • 1 Post By BIGRR

Thread: Jaeger 504 fuel sender fixed

  1. #1
    1000+ Posts BIGRR's Avatar
    Join Date
    Feb 2006
    Location
    North Rocks, Sydney
    Posts
    2,318

    Default Jaeger 504 fuel sender fixed

    My Ti fuel gauge started fooling around about 12 moths ago. Has worked perfectly and accurately since 1973. Last time I had the Ti out the gauge dropped to dead empty and stayed there.

    So today I pulled the sender out and have rectified the problem: Corrosion on the brass power pick up ring on the float arm.

    I folded a small piece of wet and dry (4 thicknesses), slid it between the brass ring pick up surfaces, spat on it and then worked the float arm full travel 10 or 20 times. This shined up the brass surfaces.

    Advertisement


    My fuel gauge now works perfectly again.
    Attached Thumbnails Attached Thumbnails Jaeger 504 fuel sender fixed-img_1723.jpg   Jaeger 504 fuel sender fixed-dsc09684.jpg   Jaeger 504 fuel sender fixed-dsc09685.jpg  
    Beano likes this.
    Present fleet:-
    Peugeot 93' 205 Gti 16v
    Peugeot 73' 504 Ti from new
    Peugeot 08' 407 Hdi Coupe from new

    Previous fleet:-
    Peugeot 95' 605 Sv
    Peugeot 92' 205 Gti
    Renault 72' 16TS from new
    Renault 69' 10
    Renault 71' 10s
    Renault 68' 10 from new

    "Be reasonable do it my way!"


  2. #2
    1000+ Posts Peter Chisholm's Avatar
    Join Date
    Aug 2004
    Location
    SWOTR
    Posts
    3,240

    Default

    Good info.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •