505 common earth
  • Register
  • Help
Results 1 to 3 of 3
  1. #1
    Member
    Join Date
    Jun 2017
    Location
    Melbourne
    Posts
    44

    Default 505 common earth

    Hi Froggers,

    After recently hitting a roo, I fitted a new headlight to my 505. While I was dicking around and otherwise getting distracted with almost every other aspect of my engine bay, I noticed a plug hanging out all by itself. The only thing near by that it could have plugged in to, was a common earth bank.

    Before I plug it in and short out god knows what...does anyone know what it's for? In the picture you can see the common earth in the background

    505 common earth-1524394711190.jpg

    Maybe this is the last time I'll have to fix it...

    Advertisement

  2. #2
    Fellow Frogger! Roland's Avatar
    Join Date
    May 2005
    Location
    Perth
    Posts
    699

    Default

    Have you plugged it in yet?
    What happened?

    What wasn't working before you plugged it in?
    Land Rover Discovery 4
    406 Coupe D9 - Manual (2002)
    307 Hdi Estate - Auto - (2007)
    307 Hdi Sedan - Auto - (2007)
    505GR Estate - Personal Import from UK 1971cc Manual (March 1986)
    405 Mi16x4 (all the parts ready to install into the LeMans body)

  3. #3
    Member
    Join Date
    Jun 2017
    Location
    Melbourne
    Posts
    44

    Default

    I did plug it in! Nothing went fizzle and pop! In fact not much happened at all.

    I unplugged it on the logic that everything seemed to be working fine without it, and decided to wait for more information before plugging it back in

    Maybe this is the last time I'll have to fix it...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •