XU10J4 Lack power 3k-4k after install RS intake.
  • Register
  • Help
Results 1 to 3 of 3
  1. #1
    Tadpole
    Join Date
    Mar 2018
    Location
    Brazil
    Posts
    1

    Default XU10J4 Lack power 3k-4k after install RS intake.

    Hi friends

    O have a Peugeot 306 S16, XU10J4 engine, and i changed the intake for the XU10J4RS. After this the engine losted power about 3000 - 4000 rpm.
    I know with the acav of the OEM intake control the air flow, but I want to know, how to tuning the afr on the chip, for to correct the lack of power about 3k-4k rpm?
    Add more or take out gasoline in this rotation range?

    Advertisement


    I have tuning and chip recorder and I try to correct the misture.

    Waiting returns, thanks.

  2. #2
    1000+ Posts Capago's Avatar
    Join Date
    Oct 2010
    Location
    Hornsby, NSW
    Posts
    1,012

    Default

    it could be both too lean or too rich. Do you have access to a wideband oxygen sensor?
    The wrong oil is better than no oil at all.

  3. #3
    Fellow Frogger! Wintermute's Avatar
    Join Date
    Apr 2005
    Location
    Sydney
    Posts
    855

    Default

    The original manifold uses a long branch for revs under 4000RPM, this increases the low end torque. The RS also has a different head and exhaust manifold, so you may find that this is just the tradeoff for changing the manifold, as it would have been optimized for use with the RS head and extractors...

    Tony.
    306 S16 1995 black
    Morris 1100 1965 green

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •