Mi16 air leak ???
  • Register
  • Help
Results 1 to 5 of 5
  1. #1
    Member
    Join Date
    May 2012
    Location
    Sydney
    Posts
    46

    Default Mi16 air leak ???

    Hi all. S1 mi16. I have an air leak in the cooling system. Car started overheating. Changed the radiator and thermostat. Car runs fine at idle but as soon as it is under load the temperature goes sky high and when I stop it blows coolant out of the radiator cap. Open the radiator bleed screw and it just blows air. Did a gas leak and pressure test and both came up fine. Also when its starts cold and sits at ilde the radiator gets hot. Drive it and the radiator is and coolant in the radiator are stone cold. But all hoses are hot ?????
    Thanks

    Advertisement

  2. #2
    1000+ Posts
    Join Date
    Nov 2010
    Location
    tweed heads
    Posts
    1,470

    Default

    Theres a bleed screw on the thermostat housing ,do a search on here re bleeding ,it can take several goes to get it right ,do you have the correct thermostat [has two valves ]air in the engine heats up and produces steam ,which is what the guage is reading ,air expands and blows coolant out the overflow ,i recall i used to make a funnel out of a milk bottle and some electrical tape, which when fitted to the filler raises the coolant level above the t stat housing ,makes bleeding easier ,there will be others more informed who will reply ,pugs

  3. #3
    Member
    Join Date
    May 2012
    Location
    Sydney
    Posts
    46

    Default

    Thanks Pugs
    I have one of those thermostats in my spares box. One in the car is single value. Tried removing it altogether still overheating but then realised fams were only running on low speed. Mow fans fans fixed

  4. #4
    1000+ Posts
    Join Date
    Nov 2010
    Location
    tweed heads
    Posts
    1,470

    Default

    Its been a long while since iv owned one of these ,my experience with modern t stats is they must be fitted ,coolant has to flow in one circuit or the other not both ,from memory starting from cold the t stat gives the heater circuit priority ,so the windscreen demists and heater works ,as the valve operates ,it deletes that bypass and circulates coolant through the rad ,if your rad is cold and engine hot ,it seems like its full of air or coolant is not circulating properly ,do a search ,im sure all of this has been covered in detail in the past pugs

  5. #5
    Member
    Join Date
    May 2012
    Location
    Sydney
    Posts
    46

    Default

    Thanks pugs.
    Heater has been bypassed at the firewall due to blown core. ?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •