207cc broken air filter housing
  • Register
  • Help
Results 1 to 9 of 9
  1. #1
    Tadpole
    Join Date
    Feb 2017
    Location
    Sydney, NSW, Australia
    Posts
    12

    Default 207cc broken air filter housing

    Have just bought a 2007 207cc convertible in showroom condition but have recently noticed a "hollow" sound coming from passenger side front. Also it is sluggish and the noise more audible under 40k. It comes up occasionally with faulty depollution system and when it did threw P2178 & P11a9 codes. It seems to have more problems when fuel tank under 1/4 e.g. DPS fault disaapeared when filled tank. I have found that the air filter housing is broken at front. Would this be causing air/fuel ratio problems and be source of noise?

    Sent from my GT-N5120 using aussiefrogs mobile app

    Advertisement

  2. #2
    1000+ Posts dmccurtayne's Avatar
    Join Date
    Jul 2013
    Location
    Newcastle/ central coast
    Posts
    1,649

    Default

    Busted cat or timing chain loose even on non turbo


    Sent from my iPhone using aussiefrogs

  3. #3
    1000+ Posts
    Join Date
    Jun 2013
    Location
    Sydney
    Posts
    8,496

    Default

    To enlarge on above- The codes indicate the system can't correct the readings from the oxygen sensor on the cat converter, and that the input timing phase shifter has reached maximum adjustment.

    It's an early engine and the chain should be checked. Many early ones, particularly turbos, but yours also, were changed while in warranty. Does it rattle (driver's side) at cold start? Converters don't thrive on excess petrol.

  4. #4
    Tadpole
    Join Date
    Feb 2017
    Location
    Sydney, NSW, Australia
    Posts
    12

    Default

    The timing chain was replaced in March prior to the sale to me. Haven't noticed any rattle drivers side either

    Sent from my GT-N5120 using aussiefrogs mobile app

  5. #5
    1000+ Posts dmccurtayne's Avatar
    Join Date
    Jul 2013
    Location
    Newcastle/ central coast
    Posts
    1,649

    Default 207cc broken air filter housing

    A blocked or broken cat can cause these faults


    Sent from my iPhone using aussiefrogs

  6. #6
    Tadpole
    Join Date
    Feb 2017
    Location
    Sydney, NSW, Australia
    Posts
    12

    Default

    Its at 98632k and I am getting 100k service done early on 15th September before a long drive up the coast. It sat garaged from March to May and wasnt driven as much as I have been since buying it. I am getting service done at Euro Prestige Vineyard. I have all parts and fluids etc for service and am just being charged labour. So do I have to change the Cat or just sensor and phase shifter? Any suggestions appreciated greatly

    Sent from my GT-N5120 using aussiefrogs mobile app

  7. #7
    1000+ Posts dmccurtayne's Avatar
    Join Date
    Jul 2013
    Location
    Newcastle/ central coast
    Posts
    1,649

    Default

    It is a non Turbo car ?


    Sent from my iPhone using aussiefrogs

  8. #8
    Tadpole
    Join Date
    Feb 2017
    Location
    Sydney, NSW, Australia
    Posts
    12

    Default

    Yes non turbo as auto 1.6 VTI

    Sent from my GT-N5120 using aussiefrogs mobile app

  9. #9
    1000+ Posts dmccurtayne's Avatar
    Join Date
    Jul 2013
    Location
    Newcastle/ central coast
    Posts
    1,649

    Default

    Try swapping the vvt valves front to rear if not at the end of this you will probably replace the cat when they go the have an odd intake noise .


    Sent from my iPhone using aussiefrogs

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •