weard cruis control, 306 HDI maual,2001
  • Help
Results 1 to 18 of 18
Like Tree1Likes

Thread: weard cruis control, 306 HDI maual,2001

  1. #1
    Tadpole
    Join Date
    Feb 2017
    Location
    Willawong, Brisbane
    Posts
    5

    Default weard cruis control, 306 HDI maual,2001

    First long trip in my Pug, fine mechanically and mileage.. All day, frustrations with cruise control, no matter what I do, on lower left stick, never go faster than 88 klm per hour.. (holding or bouncing it up) no higher.. Motor just abruptly cuts out,, sometimes slows way down, sometimes settles to 82 kph,, with slight hesitations. Never crushing above 88 kph.. All day yesterday swapping feet on accelerator to maintain 100 kph.. Frustrated,, any ideas?

    Advertisement

  2. #2
    1000+ Posts
    Join Date
    Nov 2010
    Location
    Newcastle
    Posts
    2,797

    Default

    Hi g rad
    Someone may give you a better answer, but I suspect it may be your Comm2000 unit that has failed. This is the unit under the steering wheel that all the stalks go into. It controls all the blinkers, light controls, horn, cruise control and many other things too. It is a known failure item on Pugs and Cits and cause odd symptoms in the operation of things. Any other thing works a bit oddly ??

    There are a lot of slightly different units that fit all the different models so you must get the correct one if replacing it. They are available in England if you google ebay there. You must give your VIN number to find the correct part number. We could look it up here if you like.
    Jaahn

  3. #3
    1000+ Posts
    Join Date
    Oct 2010
    Location
    Armidale
    Posts
    2,584

    Default

    Other possibilities - speedo must be working properly, and a faulty brake switch can cause problems (this was a known problem in 307s and possibly other models).

    Cheers

    Alec

  4. #4
    Fellow Frogger! dimistyle's Avatar
    Join Date
    Aug 2016
    Location
    Sunshine Coast, QLD
    Posts
    949

    Default

    Was also thinking it may just be the cruise control stalk that is a plug in unit into the existing comm2000 these are compatible between most models. You should be able to grab one from a Pug or Cit wrecker. Worth a go as they are nowhere near the $400 for a comm2000 unit.


    Sent from my SM-G900I using aussiefrogs mobile app

  5. #5
    1000+ Posts cav91's Avatar
    Join Date
    Nov 2010
    Location
    Romsey, VIC
    Posts
    2,350

    Default

    Is this definitely a 306? Because they don't have a com200 unit. There much simpler. Is it factory cruise or aftermarket?

    Sent from my SM-G930F using aussiefrogs mobile app
    2011 Renault Koleos manual petrol, yes it's boring, but not as boring as:
    2017 Renault Koleos auto

  6. #6
    Tadpole
    Join Date
    Feb 2017
    Location
    Willawong, Brisbane
    Posts
    5

    Default

    I'm 70 years young, farming background, been around all types of machines, French is new technology. Before leaving, replaced a brown relay, behind aluminum ECU. that got a light on, for locking rear windows (lower right of dash) and radiator fans. Still no air conditioning but seams slightly cooler, haven't checked air conditioning clutch,,yet, could be low on gas, but that's second priority ..looks like factory cruise control.. My Hanes workshop manual only goes to 1999. Will look for this Comm2000 module next.. thanks all.....

  7. #7
    1000+ Posts
    Join Date
    Oct 2010
    Location
    Armidale
    Posts
    2,584

    Default

    No - as CAV91 says, if it's a 306 (not a 307), then it doesn't have a COM2000 unit (which by the way is built into the combination lights and wipers switch block wrapped around the steering column).

    Does it behave normally if you ignore the Cruise control and just use the accelerator? Because the symptoms you describe sound rather like fuel starvation...

    Maybe best thing would be to post your VIN number on here - then someone can look it up and we'll know a lot more about your car

    Cheers

    Alec

  8. #8
    1000+ Posts
    Join Date
    Nov 2010
    Location
    Newcastle
    Posts
    2,797

    Default

    Hi g rad
    Here are some ebay sites from googling in the UK. Just so you can see what you might be looking for. These are not for your car, just they all look similar.. Perhaps if you give your VIN number I can look at the parts listing for you.

    It may not have one if it is an earlier model perhaps ? I do not really know much about 306s. But with cruise control I think it would have one.
    PEUGEOT / CITROEN COMMS UNIT INDICATOR WIPER STALK CLOCK SPRING SQUIB VS34572483 | eBay
    PEUGEOT & CITROEN COM UNIT COMS UNIT COM 2000 COMS 2002 COMM 2003 COMMS 2005 | eBay
    GENUINE CITROEN XSARA PICASSO 2000-2010 COMMS UNIT INDICATORS CRUISE STEREO AUTO | eBay

    Jaahn

  9. #9
    1000+ Posts
    Join Date
    Oct 2010
    Location
    Armidale
    Posts
    2,584

    Default

    Jaahn only the middle link has a list of applicable models - the 306 is notable ABSENT from the list...

  10. #10
    1000+ Posts
    Join Date
    Nov 2010
    Location
    Newcastle
    Posts
    2,797

    Default

    Quote Originally Posted by Armidillo View Post
    Jaahn only the middle link has a list of applicable models - the 306 is notable ABSENT from the list...
    Hi,
    Those references are just for seeing what a Comm2000 unit looks like ! Not everyone knows what we are talking about here on AFs, so it was not meant as a search for one at all. It may not have one at all perhaps as you said.

    As I said the only way to progress is a VIN search on the Peugeot site, which I can do IF I HAVE A VIN NUMBER for the car. That number will be on the rego papers and on the car in several places, on the identification plate, the compliance plate and under the windscreen glass along the bottom stamped in the body metal. Write it down for future reference.

    The number looks something like this; VF7DCRFNF76069702 (this is a C5) It can be checked on the factory site for full parts identification and ordering just like the dealers do.
    Cheers jaahn

  11. #11
    Tadpole
    Join Date
    Feb 2017
    Location
    Willawong, Brisbane
    Posts
    5

    Default

    You guys are awesome,,, vin. VF87BRHYE 22161898. N5? 5MT ? I called (after a week stumbling around ) Peugeot Australia, gave girl, this vin # .. she politely gave me.. radio pin. 6352. works great.. Still have five or so days on the road, in Central Highlands lap
    visiting mates..

  12. #12
    1000+ Posts
    Join Date
    Nov 2010
    Location
    Newcastle
    Posts
    2,797

    Default

    Quote Originally Posted by g rad View Post
    You guys are awesome,,, vin. VF87BRHYE 22161898. N5? 5MT ? I called (after a week stumbling around ) Peugeot Australia, gave girl, this vin # .. she politely gave me.. radio pin. 6352. works great.. Still have five or so days on the road, in Central Highlands lap
    visiting mates..
    Hi g rad
    I could not make that Vin number work on Peugeot Service box ?? It would not recognise it. So check the identification plate and see if there has been a mistake made recording the number.
    I am not familiar with a 306 and the options so I could not do a manual search that worked either. But I could not find a model which had cruise control ?? or a Comm2000 ?? I did not spend a long time there looking
    EG
    Information about the search
    0 document(s) found containing cruise control for 306 (RESTYLING)

    Anybody help here ?? Is it a rebadged Citroen for Australia ?
    Jaahn

  13. #13
    Tadpole
    Join Date
    Feb 2017
    Location
    Willawong, Brisbane
    Posts
    5

    Default

    Wonder how I got first vin🤓.. on right mud guard.. VF37BRHYE33161898 None of links to EBay comm2000, looklike my control. Unable to upload photo 🤡

  14. #14
    sans witticism SLC206's Avatar
    Join Date
    Sep 2003
    Location
    North Parramatta
    Posts
    4,025

    Default

    I'm not convinced any 306 came with factory cruise control and also most likely has a mechanical throttle.

    As for the stalks, Servicebox lists a lighting stalk, wiping stalk and sometimes an audio stalk.

    Being an aftermarket, mechanical system it would have a throttle cable connected to a control box that uses vacuum pressure (also an issue on a diesel) so probably also has some kind of pump to overcome this.

    You may have a vacuum leak or pump issue that prevents the control unit from driving the throttle cable far enough when at those speeds.

    Pure speculation, of course
    Last edited by SLC206; 18th March 2017 at 01:00 PM.
    Regards,

    Simon

    2018 308 GTi 2011 DS3 DSport
    ----
    2014 208 GTi 2007 207 GTi 2004 206 GTi180 2000 206 GTi 1995 306 XT

    www.peugeotclub.asn.au

  15. #15
    1000+ Posts
    Join Date
    Nov 2010
    Location
    Newcastle
    Posts
    2,797

    Default Correct Vin :)

    Quote Originally Posted by g rad View Post
    Wonder how I got first vin邏.. on right mud guard.. VF37BRHYE33161898 None of links to EBay comm2000, looklike my control. Unable to upload photo 嵐
    Hi g rad
    That's the one !! We will not mention the other again until ----
    As SLC206, Armadillo and CAV91 said it does not have a Comm2000. That may be good news really So it just has old style switches and stalks that work normally.
    It also did not come from the factory with cruise control; "cruise control ----WITHOUT SPEED CONTROL"

    So it is likely that the dealers had an aftermarket supplier that did a genuine looking fitment as a bulk buy before sale ! That was common before the cars all started to come with them standard. So sorry about my suggestion and just go looking for ordinary problems to fix it as suggested already.

    If you would like to contact me by Private Message, g rad to my email address and give me your email address, I can send you the factory printout of your "little baby" and all it was wearing when born
    Jaahn
    Last edited by jaahn; 18th March 2017 at 04:41 PM.

  16. #16
    1000+ Posts pgti6's Avatar
    Join Date
    May 2001
    Location
    Melbourne
    Posts
    1,652

    Default

    Jaahn, already done.

    Last edited by pgti6; 18th March 2017 at 03:57 PM.
    405 Mi16 2.2 litre race car up for sale soon. For details contact me on 0438 106 430.

    Lap times- Sandown 1 27.9
    Phillip Island 1 53.8

    Previous Frenchies-
    1988 205 Gti
    1998 306 GTi6
    1997 306 N5 sedan
    1996 306 N3 XT hatch
    1976 Renault R16TS manual in Avocado
    1976 Renault R16TS manual in Trak Yellow
    1975 Renault 5 Guernsey, Channel Islands
    1972 Renault 4 Guernsey, Channel Islands

  17. #17
    Tadpole
    Join Date
    Feb 2017
    Location
    Willawong, Brisbane
    Posts
    5

    Default

    I see my last reply didn't record.. At dawn 3 days ago, I hit a small wallaby, cruising at 100 kph. Minimal exterior damage to Pug,, it entered small black grill wrecking twin fans, pushing condenser into radiator.. Engine stopped immediately, because wiring connector separated, on lower left of radiator. Flatbed to Innot Hot Springs Auto, calling around North Queensland for replacements,, nothing so bush mechanics glued the two holes up in radiator,, I was grateful to get going again.. A day laying around the newly renovated hot springs helped.. Temp staying at 80 ish with no fan,, looking good and hope it makes it back to Brisbane.. not worried about cruise control for awhile.. thanks all.

  18. #18
    1000+ Posts
    Join Date
    Oct 2010
    Location
    Armidale
    Posts
    2,584

    Default

    Such bad luck! I have been responsible for the deaths of several kangaroos and a wallaby in my slightly bigger Pugs - a 406 & a 605. Minimal damage to either car...

    Re running without fans - avoid leaving engine idling if you are held up in traffic. Also keep air-con off except when up to cruising speed.

    Re the fans - the electric motors should still be good, so you might just need the plastic fans.

    Just had a thought - are the remnants of the fans in situ? Please tell me you didn't let the bush mechanics bin your twin fans - those motors are worth hundreds of dollars each!

    If the fans are still fitted, then if the smashed blades prevent the motors turning it might burn out the motors??

    If you have motors and need plastic blades & no-one in Brisbane is being helpful, I might be able to help.

    Cheers

    Alec

    PS - rereading your post, it looks unlikely that you would still have working air-con...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •