Microtech ECU - Page 2
  • Help
Page 2 of 2 First 12
Results 26 to 30 of 30

Thread: Microtech ECU

  1. #26
    Fellow Frogger! felixblack1's Avatar
    Join Date
    May 2002
    Location
    Brisbane
    Posts
    145

    Default

    is it a coupe?

    Advertisement


    you should come over to www.ausrotary.com

  2. #27
    Fellow Frogger! Reno's Avatar
    Join Date
    Mar 2002
    Location
    Brisbane
    Posts
    1,260

    Default

    Quote Originally Posted by felixblack1
    is it a coupe?

    you should come over to www.ausrotary.com
    already on it,

    username CX on there....

  3. #28
    Thank God for my Hydroen harrisson_citroen's Avatar
    Join Date
    Feb 2002
    Location
    Coolum Beach
    Posts
    2,048

    Default you CANT confuse the xsara for a Pug anymore!

    Geez I missed that post that said maybe some guy had bought a show car and he thought it may be a peugeot or a citroen. And someone said maybe it is Julians Xsara.

    I KNOW WHAT A CITROEN IS.

    Ask anybody in the Gold Coast area who has seen it.
    Julians Xsara now wears full CITROEN SPORT livery all with genuine total, michelin, citroen and facom logos.

    Jaws actually literally DROP when I drive past.
    It will be at St.Lucia. on show Bastille Day

    Au revoir
    DS Un jour, DS toujours !

    DS23 IE Pallas Automatique Borg Warner
    C5 X7 163 Exclusive Automatique AM6
    C3 II 2010 Automatique AL4
    Everything's gone bloody automatique!

  4. #29
    Fellow Frogger!
    Join Date
    Jun 2003
    Location
    Adelaide
    Posts
    270

    Default

    yawn, geez guys sometimes you guys never get to the point.

    I HAVE a microtech LT-8 and let me tell you, unless you are using it for racing...

    1. dont EVER let yourself be pulled over because the ecu is one of the first things the cop will send you to full inspection for

    2. its a BIATCH in terms of ecu. Go th more expensive ecu (my choice would be a motec and nothing less) because warming the car up to 60 degrees before the car will idle (otherwise the revs just drop out and it stalls) and the lack of tunability just means you miss out on plenty of power because you didnt buy the more expensive ecu.

    Simple solution, if you are a tight arse, get a piggy back or do it properly and get a motec ( or magnetti marelli if you win x-lotto)

    and if you think you're gonna get 160kw atw.... unless you are stuffing tnt in as fuel you've got a little surprise waiting when it goes on the rollers lol

    oh, as for price, i got mine for $1300 and installed for $600 AND it took the geeks at microtech 3 weeks to sort it out to work on the pug engine so get something that already works with the missing tooth

  5. #30
    Fellow Frogger! Reno's Avatar
    Join Date
    Mar 2002
    Location
    Brisbane
    Posts
    1,260

    Default

    that idle thing sounds very weird and localised to your car and setup... sounds pretty average to me....

    i never had that problem on the rx3... started first time and held idle when cold without a worry.


Page 2 of 2 First 12

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •