403 1961
  • Register
  • Help
Results 1 to 14 of 14
Like Tree6Likes
  • 2 Post By calgooley
  • 1 Post By calgooley
  • 2 Post By Peter Chisholm
  • 1 Post By Armidillo

Thread: 403 1961

  1. #1
    Member
    Join Date
    Feb 2012
    Location
    MUDGEE/NSW
    Posts
    119

    Default 403 1961

    I am soon ready to plod along with my resto of the 403. Still have to replace the air compressor to finish sanding old paint and to paint undercoat and top coats.Most probably will go with a Honda powered one altho quite expensive.I now have an electronic distributor to install obtained from der franzose. Should help a lot with tuning twin carbs. Needing to source laminated windscreen and 403 extractors.

    Advertisement


    Sent from my SM-T550 using aussiefrogs mobile app

  2. #2
    Member
    Join Date
    Feb 2012
    Location
    MUDGEE/NSW
    Posts
    119

    Default

    My new compressor is turning up this week so work on the body can continue. I am going to start her up and go for a short drive today. Have just commenced trying to get interest and support for the run to Phillip Island and thus get other 403 owners to finish their project cars .

    Sent from my SM-T550 using aussiefrogs mobile app

  3. #3
    Member
    Join Date
    Nov 2010
    Location
    Sydney
    Posts
    82

    Default

    For the laminated windscreen try Moran Motor Glass in Qld. They still had them 5 years ago when I contacted them - cost with freight was about $430. (07)33908855 136 Ingleston Road Tingalpa 4173.
    Ron Gruber had a batch of 403 extractors made up a year or so ago, but they have all been sold.
    Cheers
    Jon

  4. #4
    VIP Sponsor
    Join Date
    Aug 2000
    Posts
    9,185

    Default

    As an aside National Windscreens have 404 screens for $150 not fitted, $280 fitted.

  5. #5
    Member
    Join Date
    Feb 2012
    Location
    MUDGEE/NSW
    Posts
    119

    Default

    The new compressor is in the shed and needs final assembly.I bought a BE brand with a Chonda motor and it has electric start.....I have a shot right shoulder so this should make The job a bit easier.Im hoping to get the lammo w/screens a bit cheaper than that pontarriere. Hopefully some more 403 extractors can be manufactured also. Will need some advice on setting up the twin solex carbs on my inlet manifold. Still working on some photos of my resto to post. Hope your 403 restos are progressing well.

    Sent from my SM-T550 using aussiefrogs mobile app

  6. #6
    Member
    Join Date
    Feb 2012
    Location
    MUDGEE/NSW
    Posts
    119

    Default

    The new air compressor is running sweetly and have recommenced the paint stripping. I had a mate come and assist with the drivers fr mudguard which was a bit sorry looking. Will get the minor rust repair done soon. Need to find the correct coil for the electronic distributor and buy new leads. I have 2 good Solex 34s to put on. Ive I been busy restoring my 505 GTD turbo as well.

    Sent from my SM-T550 using aussiefrogs mobile app
    Peter Chisholm likes this.

  7. #7
    Member
    Join Date
    Feb 2012
    Location
    MUDGEE/NSW
    Posts
    119

    Default

    I'm using standard leads and coil and car starts v easily. Also have sourced a set of headers for the motor and have got a new tinted lam windscreen. No progress on the twin carb setup as yet. I have the 505GTD turbo running well and have just returned from the ACT in it after attending tje Peugeot Pageant....goes well but may swap over the injectors as I have put in ones from a 2.3l motor.......don't know if they have larger injection, so could get more power.

    Sent from my SM-T550 using aussiefrogs mobile app

  8. #8
    1000+ Posts Peter Chisholm's Avatar
    Join Date
    Aug 2004
    Location
    SWOTR
    Posts
    3,537

    Default

    Hey Cal, we are all busting to see some photos!
    Dano and Mike Tippett like this.

  9. #9
    Member
    Join Date
    Feb 2012
    Location
    MUDGEE/NSW
    Posts
    119

    Default

    Sorry about lack of photos everyone. My computer expertise is lacking in this area. Will keep trying, in meantime the resto has progressed to near completion of paint strip and primer cover. Hope to get to top coat painting next week. Can't wait to get on the road with her. Hope all your 403's are running sweet and looking forward to our meeting up next March at Phillip island.

    Sent from my SM-T550 using aussiefrogs mobile app

  10. #10
    1000+ Posts Peter Chisholm's Avatar
    Join Date
    Aug 2004
    Location
    SWOTR
    Posts
    3,537

    Default

    Cal, the lack of photos is sadistic. I'm sorry but there are many followers of your endeavours who salivate whenever you have a new post. They salivate at the prospect of you conquering the pic posting process and therefore being enraptured with your pics. So far, crestfallen is not a strong enough word.

  11. #11
    1000+ Posts Wildebeest's Avatar
    Join Date
    Oct 2004
    Location
    Perth Western Australia
    Posts
    2,678

    Default

    calgooley.
    If experiencing trouble tuning your twin Solex set up ie running rich at half/full throttle try larger air bleed jets.
    This was the case back in the day with twin Strombergs on grey Holdens.

  12. #12
    Member
    Join Date
    Feb 2012
    Location
    MUDGEE/NSW
    Posts
    119

    Default

    It is indeed very frustrating not being able to post photos on Frogs.However , my restoration of the 403 is progressing at a snails pace during the winter. My front seats are being restored and next jobs are painting the dash and boot. I'm waiting for warmer weather to put a few more top coats of alpine white acrylic on after a rub back with 800 w/dry. I'm also putting in some sound deadening on floors. No progress on the twin carby setup.....will need to get off my arse on this. Have the new w/screen and rubber. Hope your 403 projects and up and running cars are running well.

    Sent from my SM-T550 using aussiefrogs mobile app

  13. #13
    1000+ Posts Peter Chisholm's Avatar
    Join Date
    Aug 2004
    Location
    SWOTR
    Posts
    3,537

    Default

    Good to have a progress report and it sounds as though it's coming along nicely.

  14. #14
    1000+ Posts
    Join Date
    Oct 2010
    Location
    Armidale
    Posts
    2,319

    Default

    Quote Originally Posted by calgooley View Post
    It is indeed very frustrating not being able to post photos on Frogs.

    ...

    Sent from my SM-T550 using aussiefrogs mobile app
    Have you tried posting photos today? The size limit seems to have been relaxed - at least for Windows users. Have a look at this thread I started over the weekend - every one of my photos was uploaded into my posts straight from the camera, with no resizing. Snow!

    I didn't try to load more than one of these photos per post - but no special software or hosting sites was required. I don't know what 59 Floride did, but AF doesn't seem to recognise his "attachments" as pictures.

    If you are using a Windows PC, and need help with using the forum tools, let me know and I can provide screen shots and instructions. I can't help with phones, tablets or Apples of any flavour, but in theory they should be essentially the same

    Cheers

    Alec
    Dano likes this.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •