R19 heater blower removal
  • Register
  • Help
Results 1 to 3 of 3
  1. #1
    Tadpole
    Join Date
    Jun 2012
    Location
    Hobart
    Posts
    2

    Default R19 heater blower removal

    Hi all ... i have a 94 R19 (F3N) which has had an intermittent fault with the heater blower fan for some time ... it's off more than on now, and an auto electrician suggested it was probably the motor brushes ...

    however, when i started to try to remove the blower/motor i got stuck ... the heater's different to the one in the haynes manual i have (possibly because my car's got A/C?)

    anyway, can't find manuals or anything on the net, so was wondering if anyone had any tips on either removing the motor/blower assembly or removing the whole heater unit... the latter looks like a major task, and i didn't want to embark on it only to find i couldn't get it out without dismantling most of the car!

    any tips gratefully received.

    cheers
    Andrew

    Advertisement

  2. #2
    1000+ Posts
    Join Date
    Mar 2004
    Location
    Melbourne
    Posts
    5,066

    Default

    It's not too difficult Andrew,

    You need to undo a few nuts to ease the dash out a little so you can get in behind on the passanger side.
    The dash is secured with only a few nuts.
    There is one or two (3? forget) 10 mm nut(s) that hold the unit partially in place. The others you can easily get to from the front. Hope you haven't got big sausage fingers though - but it is still doable.

    The photos are from the passanger side.

    Have you made sure that the switch control on the dash is functioning first?

    If you need more photos i can take one tomorrow from a unit that is out of the car.

    Attached Thumbnails Attached Thumbnails R19 heater blower removal-p1010791.jpg   R19 heater blower removal-p1010792.jpg  
    "The enemy of knowledge is not ignorance, it's the illusion of knowledge"
    Stephen Hawking

  3. #3
    Tadpole
    Join Date
    Jun 2012
    Location
    Hobart
    Posts
    2

    Default

    fantastic! ...many thanks for that! .. yes, have checked the switch too .. the auto electrician checked all that too ... will have a go today

    thanks again ..

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •