RSC lights up around corners!
  • Help
Results 1 to 12 of 12
  1. #1
    Member
    Join Date
    Nov 2004
    Location
    Perth/Australia
    Posts
    37

    Default RSC lights up around corners!

    On a couple of occassions now during extreme cornering (well, not too extreme i.e. rear end hadnt swung out yet) the "stop" and the handbrake lights have lit up periodically and then gone off after exiting the corner.

    Anybody had this?

    Advertisement


    Perhaps an RSC's way of giving alternatives whilst navigating through the corner i.e. "stop" you idiot youre going to fast or perhaps throw the handbrake and make this corner slightly more exciting?

  2. #2
    Fellow Frogger! Reno's Avatar
    Join Date
    Mar 2002
    Location
    Brisbane
    Posts
    1,260

    Default

    i have read this before

    something to do with brake fluid. either low or should be topped up or changed.

  3. #3
    Member ParanoidAndroid's Avatar
    Join Date
    Mar 2004
    Location
    Brisbane
    Posts
    111

    Default

    Yeah its common. Mine used to do it and I made sure the airbag wiring under the seat was secure and it stopped doing it. Have a quick look under the drivers seat and make sure its plugged in properly.

  4. #4
    Member
    Join Date
    Aug 2004
    Location
    Gold Coast, Queensland
    Posts
    102

    Default

    This use dto happen on my old Swift GTi, when cornering hard the handbrake would lift up a little causing the handbrake light to come on up on the HUD, perhaps ur having the same problem with ur clio?
    JoJo

  5. #5
    1000+ Posts
    Join Date
    Dec 2003
    Location
    Sydney
    Posts
    1,160

    Default

    yeah PaulD had this one... low Brake Fluid level... the question is... where did it go!

  6. #6
    Member
    Join Date
    Nov 2004
    Location
    Perth/Australia
    Posts
    37

    Default

    Damn good question Nate!!!!! Considering i've just had the 40K service about 3 weeks ago!!!!!

  7. #7
    Fellow Frogger! biologist's Avatar
    Join Date
    Aug 2004
    Location
    Perth, Western Australia
    Posts
    867

    Default

    Quote Originally Posted by nate
    yeah PaulD had this one... low Brake Fluid level...
    the question is... where did it go!
    Check your brake pad wear, when they start to wear down, ie get thinner,
    the caliper pistons, and there are lots of them, move outwards drawing
    fluid out of the reserviour...

    Certainly got lots of options to check with this little problem though

    Cheers,
    Biologist
    ----------------
    A
    one Megane Family

  8. #8
    Good Sport danielsydney's Avatar
    Join Date
    Jul 2001
    Location
    NSW
    Posts
    4,918

    Icon2

    I think this was just a Renault thing. Im sure my Renault 19 used to do that around some corners. (not that i was going that fast in that car though)...

  9. #9
    Member
    Join Date
    Sep 2003
    Location
    Melbourne
    Posts
    105

    Default

    It's a wiring fault. My brake fluid is as full as it can go, and the light still comes on during hard cornering.

  10. #10
    Fellow Frogger!
    Join Date
    Feb 2003
    Posts
    576

    Default

    Quote Originally Posted by danielsydney
    I think this was just a Renault thing. Im sure my Renault 19 used to do that around some corners. (not that i was going that fast in that car though)...
    Or maybe you should have had it fixed Daniel. It shouldnt happen.
    2013 Grand Kangoo
    2011 Megane 3 RS
    2001 Clio Sport 172 (23/85)
    1997 Spider (No. 652)
    1988 5 GT Turbo Phase II
    1968 10

  11. #11
    Fellow Frogger! bigbadbyrnes's Avatar
    Join Date
    May 2004
    Location
    Alstonville (near Ballina) Far North NSW
    Posts
    601

    Default

    had exactly the same thing happen to me heading up to Springbrook last weekend on the drive - stop and handbrake lights sort of flickering on then staying on for a tick, then flickering out as you ease off the throttle and straighten up out of the bend.


    Dont really think it could be brake fluid as I had my servce done not 500ks ago, albeit not from the $tealership. But it was the only 20,000km anyway.


    Any further advice? Is it unsafe to be driving hard if this problem is arising?
    '87 Camry 2.0ltr injected---------5min 11 sec
    '85 Charade turbo 700cc----------5min 06 sec RESPECT
    '99 GX Impreza 2.0ltr-------------5min 02 sec
    '99 WRX w/ hi-flo exhaust------4min 46 sec
    Byrnesy's 172---------------------- 4min 25 sec

  12. #12
    1000+ Posts
    Join Date
    Dec 2003
    Location
    Sydney
    Posts
    1,160

    Default

    Possible wiring under seat?
    check the connector under the driver & passenger seat... through that normally triggers the ABS light too...

    EDIT:
    oh, just remembered..
    Does your brake light come on early enough?
    i.e. as soon as you press the pedal?
    mine wasnt & sent the system into a little fit!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •