my r12 has issues
  • Register
  • Help
Results 1 to 10 of 10
  1. #1
    Fellow Frogger!
    Join Date
    Jun 2004
    Location
    Sydney
    Posts
    396

    Default my r12 has issues

    my poor little R12 fakie has some issues still.
    it is a 72' shell with 75' interior, dash, wiring harness, etc.
    it has a 16ts motor, 15 box(4spd), and 17ts brakes and suspension.
    amongst others, it's main issue is the speedo.

    the speedo seems to read extreemly fast up to 70km/h (on the speedo), when the motor is only at about 2500-3000rpm in third gear. then it flickers around wildly for a few seconds and then sticks at 180+km/h (as far as it goes) until the ignition is completely switched off. then next time does the same thing.

    it has a brand new speedo cable in it which is appropriate for that speedo head. so my thoughts would be that the drive or the head are faulty.

    has anyone had a similar problems? or any ideas?

    Advertisement

  2. #2
    1000+ Posts Europa's Avatar
    Join Date
    Jan 2002
    Location
    Adelaide, South Australia, Australia
    Posts
    2,432

    Default

    Try a good squirt of CRC into the back of the speedo (disconnect cable, spray into the connection point)

    This has sorted out our R12 (Jaeger) from an attack of the needle bounces (and noise)
    '05 Pearl Black Mégane 5-Door LXR(Daily Driver), '75 Trak Yellow R16TSA (Parts Car), '74 Midnight Blue R17TS (Rebuilding), '73 457 Blue R17TL (Parts Car), '72 Alpine White R16TL (Retired), '69 Sunburst Brown R16TS (Awaiting Rebuild), '68 "Appliance White" Europa (Stored)

  3. #3
    1000+ Posts REN TIN TIN's Avatar
    Join Date
    Jul 2002
    Location
    Brisbane/Australia
    Posts
    2,047

    Default

    Quote Originally Posted by 3006882
    my poor little R12 fakie has some issues still.
    it is a 72' shell with 75' interior, dash, wiring harness, etc.
    it has a 16ts motor, 15 box(4spd), and 17ts brakes and suspension.
    amongst others, it's main issue is the speedo.

    the speedo seems to read extreemly fast up to 70km/h (on the speedo), when the motor is only at about 2500-3000rpm in third gear. then it flickers around wildly for a few seconds and then sticks at 180+km/h (as far as it goes) until the ignition is completely switched off. then next time does the same thing.

    it has a brand new speedo cable in it which is appropriate for that speedo head. so my thoughts would be that the drive or the head are faulty.

    has anyone had a similar problems? or any ideas?
    This sounds very odd. The speedo in an R12 is purely mechanical so shouldn't do anything unless the cable is turning and the speedo operation has no relationship to whether the ignition is on or off. I suppose it's possible for a speedo reading to be affected if there was a large electomagnet placed in very close proximity to the speedo, but there aren't any in an R12 instrument cluster.
    The R15 gearbox has a different diff ratio I think (calling Simon), so the speedo would probably indicate a lower speed than the actual and the rolling diameter of the tyres (if non-standard) would also make a difference. 70 k/hr at 3000 RPM doesn't sound that far out. My 12 does around 80 k/hr at 3000 RPM if fourth.


    Ren
    "I cannot help but notice that there is no problem between us that cannot be solved by your departure. Mark Twain"

  4. #4
    Fellow Frogger!
    Join Date
    Jun 2004
    Location
    Sydney
    Posts
    396

    Default

    well my solution is now to put in a 17TS 5spd box that i just bought.
    i know this box mates to the 16ts motor currently in the car, but i am looking at replacing the 16ts block with an 18 block and putting the 16head on it, and i am quite sure that the 17 box will mate to the 18 block, but will the 17 box match up to the 12 speedo calibrations??

  5. #5
    1000+ Posts Europa's Avatar
    Join Date
    Jan 2002
    Location
    Adelaide, South Australia, Australia
    Posts
    2,432

    Default

    Quote Originally Posted by 3006882
    well my solution is now to put in a 17TS 5spd box that i just bought.
    i know this box mates to the 16ts motor currently in the car, but i am looking at replacing the 16ts block with an 18 block and putting the 16head on it, and i am quite sure that the 17 box will mate to the 18 block, but will the 17 box match up to the 12 speedo calibrations??
    Well done if you have sourced a genuine 17TS box! A lovely set of ratios there. Be sure to check the dif for wear and tear, not unusual to see a missing tooth...

    Not sure about the speedo gear and calibrations though.
    '05 Pearl Black Mégane 5-Door LXR(Daily Driver), '75 Trak Yellow R16TSA (Parts Car), '74 Midnight Blue R17TS (Rebuilding), '73 457 Blue R17TL (Parts Car), '72 Alpine White R16TL (Retired), '69 Sunburst Brown R16TS (Awaiting Rebuild), '68 "Appliance White" Europa (Stored)

  6. #6
    Fellow Frogger!
    Join Date
    Jun 2004
    Location
    Sydney
    Posts
    396

    Default

    do you know if the diffs are interchangable with other models, eg 18, 17-4spd, fuego, etc.

  7. #7
    Simon's Avatar
    Join Date
    Jul 2000
    Location
    Adelaide
    Posts
    6,161

    Default

    Quote Originally Posted by 3006882
    do you know if the diffs are interchangable with other models, eg 18, 17-4spd, fuego, etc.
    Why stuff around with a good thing??

    Will interchange with some 395 18 5 speeds, not NG1.

    Totally not interchangeable with any four speed

    Not interchangeable with Fuego NG3

  8. #8
    Fellow Frogger!
    Join Date
    Jun 2004
    Location
    Sydney
    Posts
    396

    Default

    i was only talking of changing something if the diff was missing teeth as was suggested previously. otherwise i would not touch it, from all accounts the 17ts box is unreal.

  9. #9
    Fellow Frogger!
    Join Date
    Oct 2003
    Location
    Hampton Park
    Posts
    523

    Default

    The diffs are not "swappable", the 17TS box will require some modification of the transmission tunnel as it is a wider box (from memory). The speedo cable must be binding to cause the flicking.

  10. #10
    1000+ Posts Europa's Avatar
    Join Date
    Jan 2002
    Location
    Adelaide, South Australia, Australia
    Posts
    2,432

    Default

    Quote Originally Posted by Sherman
    The diffs are not "swappable", the 17TS box will require some modification of the transmission tunnel as it is a wider box (from memory). The speedo cable must be binding to cause the flicking.
    I think you'll find the 17TS box is just longer (due to the 5th gear), width as such is unchanged.

    Re: the needle - I actually had this effect and replaced the speedo cable only to find it made no difference! I then tried the CRC trick mentioned previously and it's never played up again (over a year now)
    '05 Pearl Black Mégane 5-Door LXR(Daily Driver), '75 Trak Yellow R16TSA (Parts Car), '74 Midnight Blue R17TS (Rebuilding), '73 457 Blue R17TL (Parts Car), '72 Alpine White R16TL (Retired), '69 Sunburst Brown R16TS (Awaiting Rebuild), '68 "Appliance White" Europa (Stored)

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •