Megane warning lights
  • Register
  • Help
Results 1 to 2 of 2
  1. #1
    Tadpole
    Join Date
    Oct 2012
    Location
    Melbourne
    Posts
    20

    Default Megane warning lights

    I have been trying to solve a problem with my son's 2008 Megane sedan. After a few kilometres of driving the ABS and ESP lights come on. If I stop the engine and then restart it the lights go off, after a minute or so, and stay off for a reasonably long time. There seems to be no pattern. The computer fault diagnosis says that it was the rear left hand wheel sensor but I swapped that with one from the wreckers and the problem remains. I also cleaned the connectors, reluctor ring and changed the fuse all to no avail. Any suggestions as to what to do next? Is this a common problem with Meganes?

    Advertisement

  2. #2
    Fellow Frogger! R17G's Avatar
    Join Date
    Jul 2002
    Location
    Gold Coast
    Posts
    329

    Default

    This may sound strange, but it is possibly an O2 sensor in the exhaust system. It is quite often linked to the abs and esp in the cars systems, but doesn't come up as the fault. I had this with a different car and once replaced, it fixed the problem. Note: There may be 2 or 3 sensors. This can be done yourself with the correct tool.
    A Gordini is still a GORDINI!!!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •