Renault 12 Indicator Issues
  • Help
Results 1 to 9 of 9
  1. #1
    Tadpole R12GL's Avatar
    Join Date
    May 2013
    Location
    Sydney
    Posts
    10

    Default Renault 12 Indicator Issues

    As our Peugeot was towed away this morning after the "Engine Fault - Repair Needed" and "Engine Temperature Fault - Stop The Vehicle" warnings appeared on screen, the 12 was called into service for a family dinner this evening.

    Advertisement


    However, for some reason the right indicator on the 12 has now decided not to work when the headlights are turned on. Left side works fine.

    I'm assuming it's some sort of connection issue and wondered if anybody may have come across this before, or have any recommendations on how to trace the fault?

    Cheers, Corey
    1974 Renault 12 GL
    2012 Peugeot 208 Allure

  2. #2
    Simon's Avatar
    Join Date
    Jul 2000
    Location
    Adelaide
    Posts
    6,203

    Default

    So it is only if the headlights are on? And I'm guessing the front blinker is blinking fast, with no rear blinker, and no blinking light on the dash or clicking? Also, you have checked for loose globes?

    If so, it sounds like a rear earthing problem. (Also assuming it is also a pre-1976 12 (so pre 12XL/1.4/Virage), with the small tail lights) For the rear lights, the upper outer light unit retaining bolt also acts as an earth to the body. Remove the light unit (the cover over the wires slides to the side rather than being pulled off, also mark which wires go where before removing them from the spade terminals), by removing the three nuts securing the light unit to the body, then also remove the upper outer bolt from the light unit, under the nut you will find the brass earthing strip to the body, clean up the connection, replace the nut, then clean up where the light unit earths to the body. Also check that where the brass strip is riveted to the light unit to earth the individual globes, that the connections are clean and sound, (in unusual circumstances the brass strip can fracture). Replace the light unit, replace the wires and check to see if it now works.
    1963 Renault R4 Van
    1964 Renault R4
    1967 Volkswagen 1300 Deluxe
    1969 Renault 8 Gordini 1300
    2002 Land Rover Defender Td5 130 - ex-CFA Region 4
    2005 Renaultsport Clio 182 Cup

  3. #3
    Tadpole R12GL's Avatar
    Join Date
    May 2013
    Location
    Sydney
    Posts
    10

    Default

    Simon, that's correct. It's only when the headlights are on. I'll investigate further tomorrow with your recommendations. Thanks!

    It's a '74 GL, and I think you may know the car. Originally owned by a Mrs Rowe in Clearview SA. I've had it about 18 months but think you may have provided the previous owner with some of its history? It was in pretty good shape and we've also done quite a bit to tidy her up.

    Cheers, Corey
    1974 Renault 12 GL
    2012 Peugeot 208 Allure

  4. #4
    Fellow Frogger! IThompson's Avatar
    Join Date
    Sep 2011
    Location
    Bendigo / VIC
    Posts
    226

    Default

    Corey,
    I have a R12 GL 75 i have a similar issue that i haven't investigated yet.

    The heater fan stops when the headlights are on.

    Ian

  5. #5
    COL
    COL is offline
    A110 COL's Avatar
    Join Date
    Mar 2002
    Location
    Van Diemen's Land
    Posts
    4,333

    Default

    Sounds like bad earth to me or dirty connections.
    Regards Col

    1973 Renault R12 Station Wagon
    1976 Renault R12 Station Wagon
    2002 Renault Laguna V6
    1973 Alpine A110

    http://alpine-a110.weebly.com/

  6. #6
    Too many posts! JohnW's Avatar
    Join Date
    Jul 2001
    Location
    Perth, WA, Australia
    Posts
    11,295

    Default

    Quote Originally Posted by COL View Post
    Sounds like bad earth to me or dirty connections.
    Yup, bad earth somewhere. Start with Simon's detailed (wow!) instructions.

    These things always sort out with systematic attention. Do one thing at a time and check whether there is an improvement or you'll never know what was wrong, and how to fix it next time, if there is a next time.

    Good luck.
    JohnW

    Renault 4CV 1950 (R1062)
    Renault R8 1965 (R1130)
    Renault Scenic Series II 2005 (wife's)
    Renault Scenic Series II 2006 (daughter's)
    Renault Scenic Series II 2007 (mine)

    CitroŽn CX Pallas 1980 (moved on to new custodian)

    National Co-ordinator, Renault 4CV Register of Australia

  7. #7
    COL
    COL is offline
    A110 COL's Avatar
    Join Date
    Mar 2002
    Location
    Van Diemen's Land
    Posts
    4,333

    Default

    The main earths are on the front left and right inner guards at the bottom right next to the radiator; at the rear lights; number plate light; interior light; door and boot switches; there are a couple of earths under the dash. Hope this helps a little
    Regards Col

    1973 Renault R12 Station Wagon
    1976 Renault R12 Station Wagon
    2002 Renault Laguna V6
    1973 Alpine A110

    http://alpine-a110.weebly.com/

  8. #8
    Tadpole R12GL's Avatar
    Join Date
    May 2013
    Location
    Sydney
    Posts
    10

    Default

    Thanks all!

    Unfortunately we can't get the tail light lense off - the head of the bottom screw is completely stripped but I'll attempt to gently drill this out on the weekend.

    We've also just realised that the tail light lenses are slightly different - the one on the right has a small chrome strip separating the indicator and brake / tail light whereas the left doesn't. Does anybody know which would be correct for this model (74 GL)?

    Cheers, Corey
    1974 Renault 12 GL
    2012 Peugeot 208 Allure

  9. #9
    Simon's Avatar
    Join Date
    Jul 2000
    Location
    Adelaide
    Posts
    6,203

    Default

    Quote Originally Posted by R12GL View Post
    We've also just realised that the tail light lenses are slightly different - the one on the right has a small chrome strip separating the indicator and brake / tail light whereas the left doesn't.
    The one with the separating chrome strip is a pattern part made by Yorka in Spain, the original is a Seima 609 (sans chrome) Made in France.

    Try just giving the RH upper nut retaining the tail light to the body inside the boot a loosen and spray with your fave contact cleaner, or CRC magic spray. The bolt is captive and retained with another nut in the tail light base so won't be lost within the light unit. If you are lucky, the poor earth may just be just the light unit connection to the body.
    1963 Renault R4 Van
    1964 Renault R4
    1967 Volkswagen 1300 Deluxe
    1969 Renault 8 Gordini 1300
    2002 Land Rover Defender Td5 130 - ex-CFA Region 4
    2005 Renaultsport Clio 182 Cup

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •