Peugeot 205 GTI Water Pump Problem
  • Register
  • Help
Results 1 to 6 of 6
  1. #1
    Fellow Frogger! WhiteKnightGTI's Avatar
    Join Date
    Apr 2012
    Location
    Sydney
    Posts
    148

    Icon1 Peugeot 205 GTI Water Pump Problem

    I recently bought a 1990 Pug GTI and the other day i noticed there was water dripping from behind the timing belt. I assume this is coming from the water pump, i need to fix it asap before it overheats and more problems develop, and i obviously cant touch it myself because of the tricky timing belt. A mechanic said it could cost around $800-1000. Can anyone confirm this problem or the quote price?
    Cheers

    Advertisement

  2. #2
    1000+ Posts schlitzaugen's Avatar
    Join Date
    Nov 2010
    Location
    loneliness capital of the world
    Posts
    9,002

    Default

    That's pretty much what you should expect. If you do the work yourself you can halve the cost and replace the belt and tensioner too if you don't have logbooks.

    These should be replaced anyway if you don't want to go there again for the belt change. Unless they were changed in the very recent past.
    ACHTUNG ALLES LOOKENPEEPERS

    Das computermachine is nicht fur gefingerpoken und mittengrabben. Ist easy schnappen der springenwerk, blowenfusen und poppencorken mit spitssparken. Ist nicht fur gewerken bei das dummkopfen. Das rubbernecken sightseeren keepen hands in das pockets-relaxen und watch das blinkenlights.

  3. #3
    1000+ Posts PeterT's Avatar
    Join Date
    Jul 2000
    Location
    Castle Hill, Sydney
    Posts
    7,483

    Default

    I will do it for $500! That's a rip off.

    '92 205 Mi16
    '90 Mi16x4

  4. #4
    1000+ Posts gezza's Avatar
    Join Date
    Nov 2010
    Location
    Bunbury
    Posts
    2,191

    Default

    Just make sure its no the metal water pipe that runs opposite it, that corrodes and starts to leak..

  5. #5
    Fellow Frogger! WhiteKnightGTI's Avatar
    Join Date
    Apr 2012
    Location
    Sydney
    Posts
    148

    Default

    ok thanks, ill have to get under it and have another look

  6. #6
    Fellow Frogger!
    Join Date
    Nov 2010
    Location
    Melbourne
    Posts
    265

    Default

    Take off the top cover and make sure it isn't the welshplug

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •