Pug 306 electrics
  • Register
  • Help
Results 1 to 5 of 5
  1. #1
    Tadpole
    Join Date
    Sep 2011
    Location
    Perth
    Posts
    15

    Default Pug 306 electrics

    All of a sudden my Pug 306 (94) just started acting odd!

    The ignition felt funny - the car started without me really turning it on.

    The battery light is on and it drives fine but nothing electrical works (indicator/radio/fans) etc.
    Any idea?

    Advertisement

  2. #2
    1000+ Posts cav91's Avatar
    Join Date
    Nov 2010
    Location
    Romsey, VIC
    Posts
    2,328

    Default

    sounds like the igntion switch has packed up.
    2011 Renault Koleos manual petrol, yes it's boring, but not as boring as:
    2017 Renault Koleos auto

  3. #3
    Tadpole
    Join Date
    Sep 2011
    Location
    Perth
    Posts
    15

    Default

    Yeah thanks - I reckon you are right.
    Whats the damage?

  4. #4
    1000+ Posts cav91's Avatar
    Join Date
    Nov 2010
    Location
    Romsey, VIC
    Posts
    2,328

    Default

    Dave Cavanagh at French Connection has a few for $77
    2011 Renault Koleos manual petrol, yes it's boring, but not as boring as:
    2017 Renault Koleos auto

  5. #5
    Tadpole
    Join Date
    Sep 2011
    Location
    Perth
    Posts
    15

    Default

    cheers mate!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •