406 Airbag warning light
  • Register
  • Help
Results 1 to 5 of 5
  1. #1
    Member
    Join Date
    Jan 2011
    Location
    Adelaide
    Posts
    78

    Default 406 Airbag warning light

    Hello all,
    We have an airbag warning light and "tone" (read annoying buzzer) just after the car has started. This has been going on for some time and is consistent.
    Does anyone have any clues as to the cause & fix? (cue 505604....)
    Thanks,
    FarmPug

    Advertisement

  2. #2
    the famous 18E pug206gti's Avatar
    Join Date
    May 2005
    Location
    lost
    Posts
    11,055

    Icon6

    G'day,
    is it a similar situation to the 206gti mentioned elswhere? Could be a loose connector under the front seat.
    regards,
    Les W.


    206 GTi 180
    the stealth Pug
    Did I do anything last night that suggested I was sane?








  3. #3
    Fellow Frogger! 505604's Avatar
    Join Date
    Jul 2002
    Location
    Junee, NSW
    Posts
    758

    Default

    Hi FarmPug,

    You must have a later model than I do. I don't get the privilege of annoying buzzers!

    So far in my quest to eliminate the airbag warning light, I have had both front seat belt stalks replaced - cost around $1100 - and last time the dealer said there was a connector deep in the dash area which was loose. Once he got down to it, he found that it was not only loose, but corroded and needed replacing.

    I think he spent about 3 hours tracing and replacing it - all for a $5 connector. Very nice of him not to charge me for all that labour, most of which was diagnostics.

    I'm now looking at the 'clock spring' in the steering wheel hub?

    Each fix that has been undertaken has stopped the light for a while, maybe up to 3 months at a time, so I'm confident that each one has been a genuinely faulty item. I'm just wondering how many more things there are that can go wrong with the system.

    I've been told to look for loose connectors under the seats, as pug206gti suggested, but I've never found any evidence that there was any problem there. Your car might be different, though.

    HTH.

    Andrew
    Current cars: Peugeot 307 HDi Touring; Peugeot 306 Cabriolet; Peugeot 406 HDi, Peugeot 505 Familiale
    Previous cars: 1965 Peugeot 404; 1972 Renault 16TS; 1970 Peugeo 504 1800; 1978 Peugeot 504 GL; 1976 Peugeot 504 LTI; 1984 Peugeot 505 Familiale; 1982 Peugeot 604 (converted to TD) 1999 Peugeot 306 Cabriolet

  4. #4
    Fellow Frogger!
    Join Date
    Dec 2002
    Location
    CANBERRA
    Posts
    400

    Default

    I've had success with connections under the seats. Disconnected them and sprayed with contact cleaner and refitted. Light now stays off.

    Cheers

    Jim

  5. #5
    the famous 18E pug206gti's Avatar
    Join Date
    May 2005
    Location
    lost
    Posts
    11,055

    Icon6

    G'day,
    yea, well done.
    regards,
    Les W.


    206 GTi 180
    the stealth Pug
    Did I do anything last night that suggested I was sane?








Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •