1999 306 radiator fan issue
  • Register
  • Help
Results 1 to 7 of 7
  1. #1
    Fellow Frogger!
    Join Date
    Nov 2010
    Location
    S.E Melbourne
    Posts
    190

    Default 1999 306 radiator fan issue

    Hi all
    So last couple of days I have noticed that when I am in slow moving traffic or stopped, my water temperature is rising up above normal.

    Now I had a look at it didn't seem like the 2 radiator fans were working.

    So I took the front bumper off and the 2 fans just fell down, i.e they were not on the shafts of the motor.

    I pushed them back on, and turned the car on and put A/C on full blast, and both fans spun fine, until they spun themselves off the shaft. So this must be why my car was overheating, because the fan blades were not on the shafts.

    I am just wondering if they are suppose to be fixed onto the shafts somehow. As from what I can see mine have nothing to hold them on, so I assume whatever did hold it on has broken off.

    Will I need to replace the whole fan housing? Or can I just get some new clips or whatever holds them on.

    I will take photos and a video to explain more.

    Thanks in advance.

    P.S - Does anyone know if it is ok to drive to work and back with no front bumper? Legally and for the car!

    Thanks

    Some pictures, with a video to come.

    The way it looked when I took the front bumper off.




    The shaft from the motor as I found it. Is the groove near the end for a clip?




    What it looks like when I pushed the blades back on

    Advertisement


    Last edited by nomis; 16th February 2012 at 05:53 PM.

  2. #2
    1000+ Posts Andrew Ch's Avatar
    Join Date
    Nov 2010
    Location
    Melbourne Australia
    Posts
    1,382

    Default

    My bet is that the groove on the end of shaft is for a circlip which is a push in to the groove tight fit. That should be a simple fix as long as you get correct size.

    Up to you to take a punt without bumper as the front number generally attaches to it good luck.

  3. #3
    1000+ Posts
    Join Date
    Dec 2005
    Location
    HOBART
    Posts
    1,265

    Default

    There will be a circlip and possibly a washer holding them on. The earlier models had a left hand thread screw, so this is another variation.
    1998 Peugeot 406 D8SV Manual
    1999 Peugeot 406 D8ST Auto
    2002 Peugeot 406 D9SV Manual
    1994 Peuegot 306 N3 Cabriolet Manual
    1994 Peugeot 306 XR N3 Hatch
    1995 Peugeot 505 GTI executive
    1976 Peugeot 504 Sedan - Now sold

    Over 60 Pugs in my time
    Gerry Mullock

  4. #4
    Fellow Frogger!
    Join Date
    Nov 2010
    Location
    S.E Melbourne
    Posts
    190

    Default

    Well I have made some 'clips' out of twisted wire which will hopefully keep them on until I can get some proper replacements.

    Does anyone know specifically what is needed, what sizes?

    Here is the video I recorded lol
    http://youtu.be/FeIF_NgMfQQ

  5. #5
    1000+ Posts Andrew Ch's Avatar
    Join Date
    Nov 2010
    Location
    Melbourne Australia
    Posts
    1,382

    Default

    Washer x 2, Circlips x 2 is what you need as suggested.......

    Measure shaft diameter drive to nearest Autoparts shop tell them what need, make sure they fit in carpark before you leave .....

  6. #6
    1000+ Posts
    Join Date
    Dec 2005
    Location
    HOBART
    Posts
    1,265

    Default

    I ended up getting the fans off nomis.

    The pins had broken off so I went to the local nuts and bolts shop and for a few dollars bought some new pins and some U clips and they back ready for use. I am a little dubious about the clips as they don't seem to be very strong, and standard round circlips wont fit. Peugeot may yet stock the clips and if so I'll get some
    1998 Peugeot 406 D8SV Manual
    1999 Peugeot 406 D8ST Auto
    2002 Peugeot 406 D9SV Manual
    1994 Peuegot 306 N3 Cabriolet Manual
    1994 Peugeot 306 XR N3 Hatch
    1995 Peugeot 505 GTI executive
    1976 Peugeot 504 Sedan - Now sold

    Over 60 Pugs in my time
    Gerry Mullock

  7. #7
    Fellow Frogger!
    Join Date
    Nov 2010
    Location
    S.E Melbourne
    Posts
    190

    Default

    Good to hear you got them going pugnut1 !

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •