Help needed and advice for mi 16...
  • Register
  • Help
Results 1 to 5 of 5
  1. #1
    Tadpole
    Join Date
    Sep 2011
    Location
    North Avoca
    Posts
    24

    Default Help needed and advice for mi 16...

    Hi,
    I have a problem with my mi 16....it has a slight miss at low revs up to 2000 revs then its not there.
    But sometimes it not there at all....the engine light is not on and works....the coils are ok and I put new plugs in it........any help would be good.

    wayne

    Advertisement

  2. #2
    Fellow Frogger! paulrb's Avatar
    Join Date
    Dec 2004
    Location
    Geelong
    Posts
    214

    Default

    Try the distributor cap. These seem to have a strong effect on the car idling smoothly.

    I have to clean the inside terminals on mine every couple of months with a die grinder. This instantly improved the car's idle.
    Current Beasts:
    '89 405 Mi16
    '98 406 ST TD Wagon
    '90 405 MI16
    '67 Morris Mini

    Recent Pugs..
    '94 306 XR
    '01 306 XT
    '98 306 XT

  3. #3
    Tadpole
    Join Date
    Sep 2011
    Location
    North Avoca
    Posts
    24

    Default mi 16 stuff

    Thanks for that I will try it straight away.... Wayne

  4. #4
    1000+ Posts
    Join Date
    Nov 2010
    Location
    tweed heads
    Posts
    1,499

    Default Coils

    as ,hes saying coils im presuming its an S2 try running it at night with no lights around and see if you can see any stray sparks PUGS

  5. #5
    Tadpole
    Join Date
    Sep 2011
    Location
    North Avoca
    Posts
    24

    Default thanks

    Thanks...I'll try that.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •