505 GTi computer failed
  • Register
  • Help
Results 1 to 4 of 4
  1. #1
    1000+ Posts okalford's Avatar
    Join Date
    Sep 2004
    Location
    Melbourne
    Posts
    10,968

    Icon11 505 GTi computer failed

    My car broke down last week and it turns out it was the computer. It now has a replacement second hand computer and is running ok again. The Peugeot place that diagnosed it said it was the first time they have ever had to replace one in a 505 GTi. Out of curiosity; has anyone else ever had to replace one?

    Advertisement




    Pics of the failed one:
    Attached Thumbnails Attached Thumbnails 505 GTi computer failed-jetronic.jpg   505 GTi computer failed-jetronic-505.jpg  
    Last edited by okalford; 21st May 2011 at 10:26 PM. Reason: pics

  2. #2
    1000+ Posts Gamma's Avatar
    Join Date
    Oct 2004
    Location
    Picton NSW
    Posts
    1,412

    Default

    No.
    I do have a spare one in case of anyone else having a problem.
    /// 1986 SII 505 GTI
    2003 T5 307 HDI
    2013 LandRover90
    Sacred cows make the best hamburger mince.
    If you run, you only die tired

  3. #3
    Fellow Frogger! Ikenna351's Avatar
    Join Date
    Nov 2010
    Location
    Abuja, Nigeria.
    Posts
    297

    Default

    Quote Originally Posted by okalford View Post
    My car broke down last week and it turns out it was the computer. It now has a replacement second hand computer and is running ok again. The Peugeot place that diagnosed it said it was the first time they have ever had to replace one in a 505 GTi. Out of curiosity; has anyone else ever had to replace one?



    Pics of the failed one:

    I intend to replace mine, 505 V6 Injection ECU, by end of this week. The symptoms the car is having is excessive fuel, including black smoke from the exhaust.

    So Okalford, what symptom did yours gave when it failed? Just what to be sure mine is the cause of the excessive fuel.

    Ikennna.

  4. #4
    1000+ Posts okalford's Avatar
    Join Date
    Sep 2004
    Location
    Melbourne
    Posts
    10,968

    Default

    Quote Originally Posted by Ikenna351 View Post
    I intend to replace mine, 505 V6 Injection ECU, by end of this week. The symptoms the car is having is excessive fuel, including black smoke from the exhaust.

    So Okalford, what symptom did yours gave when it failed? Just what to be sure mine is the cause of the excessive fuel.

    Ikennna.
    It ran like, well it would not run. It did 5km an hour and sounded horrible with no power at all. The RACV towed it away to a safety zone and later for repair. It was the worse I had ever seen it run. It failed suddenly btw, with no warning. It was ok one minute and then had a total failure.
    Last edited by okalford; 23rd May 2011 at 10:08 PM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •