405 sri
  • Register
  • Help
Results 1 to 3 of 3

Thread: 405 sri

  1. #1
    Tadpole IBLOWN's Avatar
    Join Date
    Feb 2006
    Location
    Penrith, Sydney
    Posts
    25

    Default 405 sri

    my 94 sri is starting to get rather hot (around 110 deg) the high speed fan wont come on. it came on once when the dreaded STOP light came on. I dont think its the water pump because when revs are up it starts to cool. Any suggestions?

    Advertisement
    Peugeot 405 sri 94' everyday. Commodore once a month.

    http://www.cardomain.com/ride/2213367

  2. #2
    Fellow Frogger! Decca's Avatar
    Join Date
    Jul 2004
    Location
    Canberra
    Posts
    896

    Default

    gets hot when moving or just when stuck in traffic?

    Sounds like the fans are ok if they come on with the stop light.
    check wiring to the temp sensor and maybe the relay/s that operate the fans may be crook.

    There was a link mentioned in AF that had the wiring explanation regarding the fans in a 405. cant seem to find it. hopefully an AFer will find it for you.

    but basically low fan speed is set by having the two fans in series, ie they get 6volts each. High speed they both get 12volts and this is achieved through three relays.


    Decca
    Present --2016 2008 Outdoor / 2014 RAV4 Diesel (My utilitarian beast)

    Past -- 19?? 403 / 1974 504GL / 1972 R12TL / 1995 405SRi / 1997 406ST / 1998 306XT / 2004 406HD1 / 2008 308XSE HDi / 2008 307XSE

  3. #3
    Tadpole IBLOWN's Avatar
    Join Date
    Feb 2006
    Location
    Penrith, Sydney
    Posts
    25

    Default

    cheers for that!
    Peugeot 405 sri 94' everyday. Commodore once a month.

    http://www.cardomain.com/ride/2213367

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •