205 Bonnet Release goes Bang
  • Register
  • Help
Results 1 to 6 of 6
  1. #1
    Tadpole
    Join Date
    Jul 2005
    Location
    Sydney
    Posts
    13

    Default 205 Bonnet Release goes Bang

    Hi All.

    I went to top up the oil today in my 93 Si, pulled the bonnet release and the damn thing snapped the cable and almost took my finger off!

    Has anyone out there had to replace their bonnet release cable? Is there a way to do it without taking the dash off?

    Thanks

    Advertisement

  2. #2
    Fellow Frogger!
    Join Date
    May 2002
    Location
    Adelaide
    Posts
    642

    Default

    I'm not 100% but it should be like the speedo cable, there should be a grommet in the firewall that the cable goes through, that way you should be able to feed the new cable through.
    05' Megane 225 Cup

  3. #3
    SMP addict pugjet's Avatar
    Join Date
    May 2002
    Location
    Enruoblem
    Posts
    2,098

    Default

    yah i had the bonnet cable snap in my s1 gti, earlier this year.

    youll be able to feed another cable through the existing grommet. you wont have to dismantle the dash, unless of course youve pulled the plastic cable surround all the way out!

    if you want access to the bonnet, the easiest way is to sacrifice the front grille, and push the bonnet latch open with a screw driver.

    once open, just feed another cable through said grommet, and attatch the other end to the bonnet lock mechanism found behind the front grille.

    sounds simple enough but is the biggest pain in the arse.

    current frogs :
    '94 s3 alpine 205GTi

    daily ding magnet: '98 1.8 16v citroen xsara


    previous frogs:

    88 S1 205GTi
    '95 306S16


    gimme corners. . .


  4. #4
    Fellow Frogger! WAUTY205's Avatar
    Join Date
    Jun 2004
    Location
    Devonport, TAS
    Posts
    181

    Default

    Quote Originally Posted by pugjet
    if you want access to the bonnet, the easiest way is to sacrifice the front grille, and push the bonnet latch open with a screw driver.
    Snapped on me too about 2 mths ago. I was like NOOOOOOOOOOOO!!!!
    Especialy as I was on my own in the snow, miles from nowhere with no mobile coverage & the starter wouldn't turn .

    But I was able to lay on my back & fit one hand up between the inlet manifold & radiator & push the catch accross while the other hand pulled down on the bonnet to make it easier. Took seconds to get the bonnet open .

    BTW got the car started after wiggleing the starter ignition wire. Phew!

    I found the easiest way to fix was just to fit a new inner cable & slide it from the inside up the original outer shield from the inside. Again, only took a few minutes.

    Will
    1990 205Gti
    1976 504 rally car (currently out of action)

  5. #5
    SMP addict pugjet's Avatar
    Join Date
    May 2002
    Location
    Enruoblem
    Posts
    2,098

    Default

    Quote Originally Posted by WAUTY205
    Snapped on me too about 2 mths ago. I was like NOOOOOOOOOOOO!!!!
    Especialy as I was on my own in the snow, miles from nowhere with no mobile coverage & the starter wouldn't turn .

    But I was able to lay on my back & fit one hand up between the inlet manifold & radiator & push the catch accross while the other hand pulled down on the bonnet to make it easier. Took seconds to get the bonnet open .

    BTW got the car started after wiggleing the starter ignition wire. Phew!

    I found the easiest way to fix was just to fit a new inner cable & slide it from the inside up the original outer shield from the inside. Again, only took a few minutes.

    Will
    hi will, thats a fair effort, specially miles in the middle of nowhere.

    my cable snapped 10cms from the bonnet latch, and just connected it together with a piece of cable i found at bunnings.

    where did you get your cable from?

    current frogs :
    '94 s3 alpine 205GTi

    daily ding magnet: '98 1.8 16v citroen xsara


    previous frogs:

    88 S1 205GTi
    '95 306S16


    gimme corners. . .


  6. #6
    Fellow Frogger! WAUTY205's Avatar
    Join Date
    Jun 2004
    Location
    Devonport, TAS
    Posts
    181

    Default

    Quote Originally Posted by pugjet
    where did you get your cable from?
    In my case I was able to use the same cable as it was a fair bit too long to start with (it snapped right on the catch too), but I only just put new cables in my push bike & found that they would be heaps long enought.
    1990 205Gti
    1976 504 rally car (currently out of action)

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •