My pug needs help!
  • Register
  • Help
Results 1 to 2 of 2
  1. #1
    Fellow Frogger!
    Join Date
    Jul 2002
    Location
    new zealand
    Posts
    158

    My pug needs help!

    right my xsi is having problems blowing hot air into the car - aka heater not working. any ideas? also on the left air vent a noise is coming out, high pitched squeel that is there sometimes then not there at other times. hmm odd. engine acceleration is heavy up the hills why o why? oil gauge and petrol gauge goes up and down some times like a yo yo. i checked the oil the other day and even though it said on the dash in the car it was full there was none on the dip stick. also how do i get to the led's behind the heater dials etc? is it worthwhile me taking the mouldings of my car to get them sprayed? cheers.

    Advertisement

  2. #2
    Budding Architect ???? pugrambo's Avatar
    Join Date
    Jul 2000
    Location
    Parkes - N.S.W - Australia - Earth
    Posts
    12,269
    i'll answer the easy question here
    paint the mouldings for sure
    they make the car look younger and smoother
    3 x '78 604 SL

    1 x 2018 3008

    1 x 2000 Citroen XM,

    1 x '98 306 GTi6 sadly sold

    1 x secret project

    1 x '98 406 STDT troop carrier and i don't care if it stinks, i don't sniff it's arse Death by wank tank

    1 x '99 406SV 5spd wagon, time to burn more fuel

    1 x 1994 605 SV3.0

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •