505 s/w reverse lights
  • Register
  • Help
Results 1 to 6 of 6
  1. #1
    Tadpole
    Join Date
    Jun 2004
    Location
    Melbourne
    Posts
    14

    Default 505 s/w reverse lights

    Does anyone have a solution to the problem of reverse lights not working on 505 autos. Mine is an 85 SR wagon, and I don't know whether it applies to sedans as well.
    So far, expert advice is that the switch or housing wears and even a new switch does not fix it. Adjusting the seating of the switch with bushes can get starting or reverse lights, but not both.

    Any ideas?

    Advertisement

  2. #2
    1000+ Posts Gamma's Avatar
    Join Date
    Oct 2004
    Location
    Picton NSW
    Posts
    1,412

    Default

    Start by testing the switch.
    Use a suitable lever to see if extra travel will restore the lights.
    If switch OK, work back to globes, (or first start with the globes).
    /// 1986 SII 505 GTI
    2003 T5 307 HDI
    2013 LandRover90
    Sacred cows make the best hamburger mince.
    If you run, you only die tired

  3. #3
    Tadpole
    Join Date
    Jun 2004
    Location
    Melbourne
    Posts
    14

    Default

    Globes OK, powers OK, switch OK, even brand new switch won't turn on reverse lights.

  4. #4
    1000+ Posts Gamma's Avatar
    Join Date
    Oct 2004
    Location
    Picton NSW
    Posts
    1,412

    Default

    Check wiring continuity????
    Remove switch and manually move to on position while connected. (Ign on in PK).
    If the selector is worn, then the fix is difficult. Start replacing worn bits.
    /// 1986 SII 505 GTI
    2003 T5 307 HDI
    2013 LandRover90
    Sacred cows make the best hamburger mince.
    If you run, you only die tired

  5. #5
    Fellow Frogger! Ralph's Avatar
    Join Date
    Jul 2001
    Location
    Wodonga
    Posts
    928

    Icon7

    Mine does the same thing, no lights in reverse. It also won't start sometimes. I find by getting under the left hand side of the car and belting the switch with four wires coming out of it on the gearbox solves both problems. It must be a combo reverse lights/don't start in gear switch. You can adjust the linkages into the box to fix the problem properly I've been told. I plan to fix mine by fitting a BA7/5.


    Matt.
    On the internet, no one knows that you are only wearing a fez.

  6. #6
    Tadpole
    Join Date
    Jun 2004
    Location
    Melbourne
    Posts
    14

    Default

    belting the switch with four wires coming out of it on the gearbox solves both problems.
    What size hammer?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •