Emissions Light on Peugeot 4007
  • Help
Results 1 to 9 of 9
  1. #1
    Tadpole
    Join Date
    Aug 2015
    Location
    Melbourne
    Posts
    16

    Default Emissions Light on Peugeot 4007

    Hi all my emissions lght on my Peugeot 407 has just come on Before the light come it was making a small whining noise when I turned the ignition off (not the motor) my question is that I am about 150 K from home on holidays and was wondering in general would it be ok to drive the car home in that distance and does anybody here have a rough idea of what the problem could be related to the warning light

    Thanks

    Advertisement

  2. #2
    1000+ Posts dmccurtayne's Avatar
    Join Date
    Jul 2013
    Location
    Newcastle/ central coast
    Posts
    2,222

    Default

    Go to a super cheap auto get the codes scanned and put results here itís only 20 bucks or so.


    4008
    Gone but not forgotten C5 x7 3008 206 GTI 180 306 XR SED 405 MI16 x2 xzara VTS 406 SV 206 XT Berlingo 2011 (best car ever) 306 HDI 307 XSE HDI touring
    Fix it right the first time
    Garage C5 X7 4008
    Gone but not forgotten 3008 206 GTI 180 306 XR SED 405 MI16 x2 xzara VTS 406 SV 206 XT Berlingo 2011 (best car ever) 306 HDI 307 XSE HDI touring
    Fix it right the first time

  3. #3
    1000+ Posts
    Join Date
    Jun 2013
    Location
    Sydney
    Posts
    9,332

    Default

    Internal whines and hums are usually the heater/AC unit ding its usual business. You don't say which engine, but there are many depollution fault possibilities. Could be lots of things and needs a code read. You might be just blowing diesel crap, or poisoning an expensive catalytic converter.

    Take it gently and get it code read.

    Edit: pipped to the post. See above.

  4. #4
    Tadpole
    Join Date
    Aug 2015
    Location
    Melbourne
    Posts
    16

    Default

    Quote Originally Posted by dmccurtayne View Post
    Go to a super cheap auto get the codes scanned and put results here it’s only 20 bucks or so.


    4008
    Gone but not forgotten C5 x7 3008 206 GTI 180 306 XR SED 405 MI16 x2 xzara VTS 406 SV 206 XT Berlingo 2011 (best car ever) 306 HDI 307 XSE HDI touring
    Fix it right the first time
    Thanks for the reply and any super cheap auto store will do that ?

  5. #5
    Tadpole
    Join Date
    Aug 2015
    Location
    Melbourne
    Posts
    16

    Default

    Ok that might make sense regarding the Internal whines and hums and the heater/AC unit as I have just purchased the car and only using the Air con now Its a diesel 1.6 engine 2013 model

  6. #6
    1000+ Posts dmccurtayne's Avatar
    Join Date
    Jul 2013
    Location
    Newcastle/ central coast
    Posts
    2,222

    Default

    Yes all supercheap do it now diesel 1.6 407 in 2013 in Australia?????


    4008
    Gone but not forgotten C5 x7 3008 206 GTI 180 306 XR SED 405 MI16 x2 xzara VTS 406 SV 206 XT Berlingo 2011 (best car ever) 306 HDI 307 XSE HDI touring
    Fix it right the first time
    Garage C5 X7 4008
    Gone but not forgotten 3008 206 GTI 180 306 XR SED 405 MI16 x2 xzara VTS 406 SV 206 XT Berlingo 2011 (best car ever) 306 HDI 307 XSE HDI touring
    Fix it right the first time

  7. #7
    1000+ Posts
    Join Date
    Jun 2013
    Location
    Sydney
    Posts
    9,332

    Default

    What are digits 6-7-8 in the VIN (see undr windscreen)? This is the engine code.

  8. #8
    Tadpole
    Join Date
    Aug 2015
    Location
    Melbourne
    Posts
    16

    Default

    Quote Originally Posted by dmccurtayne View Post
    Yes all supercheap do it now diesel 1.6 407 in 2013 in Australia?????


    4008
    Gone but not forgotten C5 x7 3008 206 GTI 180 306 XR SED 405 MI16 x2 xzara VTS 406 SV 206 XT Berlingo 2011 (best car ever) 306 HDI 307 XSE HDI touring
    Fix it right the first time

    Sorry my bad 4007 diesel 2.0 litre

  9. #9
    Tadpole
    Join Date
    Aug 2015
    Location
    Melbourne
    Posts
    16

    Default

    The emissions light is now coming off and on but it did seem to stutter for the first time whilst driving it today,but is driving generally fine with no problems the light did come on but after 5 minutes then went off An interesting note just checked the service logs and the previous owner had a minor service at 78 K but log books stared it should have been a major service could the problem be related to a fuel filter not been serviced for a while ?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •