Water in Fuel Filter fault code
  • Register
  • Help
Results 1 to 3 of 3
  1. #1
    WFH
    WFH is offline
    Tadpole
    Join Date
    May 2019
    Location
    Brisbane
    Posts
    2

    Default Water in Fuel Filter fault code

    Hi all, I am new to Pugs so please excuse my ignorance.
    My 2004 4007 2.0 HDI stopped running suddenly refused to restart and the Water in Fuel Filter fault code was now displayed.

    I have drained the filter housing and installed a new filter but alas the engine will still not start and the fault code remains.

    Advertisement


    I thought resetting the BSI might resolve the problem but I am missing one key element I do not have a central locking remote (or one that works) which appears to be required for the reset procedure.

    Any guidance would be greatly appreciated.

    Regs
    Bill

  2. #2
    1000+ Posts dmccurtayne's Avatar
    Join Date
    Jul 2013
    Location
    Newcastle/ central coast
    Posts
    1,645

    Default

    The bsi reset is bs donít pay attention to that , was there water in the diesel and have you bled the system with the bulb before starting itís easy to recheck for water using the filter


    Garage C5 X7 3008 XTE
    Gone but not forgotten 206 GTI 180 306 XR SED 405 MI16 x2 xzara VTS 406 SV 206 XT Berlingo 2011 (best car ever) 306 HDI 307 XSE HDI touring
    Fix it right the first time

  3. #3
    WFH
    WFH is offline
    Tadpole
    Join Date
    May 2019
    Location
    Brisbane
    Posts
    2

    Default

    One further thing to add. I can unplug the water sensor plug and contact directly to the battery. The warning light goes out and the engine starts....disconnect the power and the engine stops

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •