306 XSI cabin fan running full speed
  • Register
  • Help
Results 1 to 4 of 4
Like Tree2Likes
  • 1 Post By alpine
  • 1 Post By Demannu

Thread: 306 XSI cabin fan running full speed

  1. #1
    Fellow Frogger!
    Join Date
    Apr 2014
    Location
    Orange
    Posts
    378

    Default 306 XSI cabin fan running full speed

    The 306 work beater has been sitting unused for 5 weeks in the hot sun as my wife broke her foot and I got the good car. When I got in this morning it fired up fine but the internal cabin fan decided it would go full speed and the fan speed switch does nothing. Any idea what I need to look at other than pulling the fuse?

    Advertisement


    Good old french electrics. The airbag light came back on to tease me after going away for a few months after wiggling the passenger seat connector and the left door speaker decided to go mute too I wonder how much longer I can keep her running.

  2. #2
    Fellow Frogger!
    Join Date
    Oct 2003
    Location
    canberra
    Posts
    859

    Default

    most likely the module attached to bottom of the fan , can buy on ebay from china cheaply
    Warus likes this.

  3. #3
    Demannu-facturing! Demannu's Avatar
    Join Date
    Dec 2002
    Location
    Menzies Creek
    Posts
    2,541

    Default

    Yep, the transistor module on the bottom of the unit has gone short.

    As alpine said, you can get them from China. Another option, which I've had great success with, is to replace the transistors themselves with equivalents from Jaycar/RS Components/Element14/etc.
    Warus likes this.
    Scotty

    Melbourne - Dandenong Ranges

    1956 Peugeot 403 - 'Francois' - resto project

    1969 Peugeot 504 - 'Pascal' - daily driver project

    1970 Peugeot 404 Utility - 'Brutus' - resto project

    1978 Peugeot 604 - as yet unnamed - V6 on straight LPG

    1987 Peugeot 505 - as yet unnamed - project car

    1999 Peugeot 406 Coupé - 'Chloe' - 5 speed manual

    2011 Peugeot 3008 XTE HDi - 'Zoe' - hatchback on steroids

    2014 Peugeot RCZ - 'Remy'

    1999 Range Rover 4.6 HSE - 'Grover' - tow car

  4. #4
    Fellow Frogger!
    Join Date
    Apr 2014
    Location
    Orange
    Posts
    378

    Default

    Awesome thanks for the direction I will have a look at it.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •