207 cc Electrical issues
  • Register
  • Help
Results 1 to 3 of 3
  1. #1
    Tadpole
    Join Date
    Feb 2017
    Location
    Sydney, NSW, Australia
    Posts
    12

    Default 207 cc Electrical issues

    Hi,

    I seem to be having continuing electrical issues on passenger side of car e.g tail lights and head lights keep blowing. Headlight set less than six moths old and I had a spare tail light globe as bought two not much before then as well. I also keep getting a side lamp faulty which I thought was to do with the side mirror light but it is working fine. Any suggestions appreciated

    Advertisement


    Sent from my SM-G900I using aussiefrogs mobile app

  2. #2
    Fellow Frogger! dmccurtayne's Avatar
    Join Date
    Jul 2013
    Location
    Newcastle/ central coast
    Posts
    690

    Default

    Loose earth points or bad connection at h7 globes the side lights could be number plate globes or front parkers


    Garage C5 X7 3008 XTE
    Gone but not forgotten 206 GTI 180 306 XR SED 405 MI16 x2 505 GR xzara VTS 406 SV 206 XT Berlingo 2011 (best car ever) 306 HDI 307 XSE HDI touring
    Fix it right the first time

  3. #3
    Tadpole
    Join Date
    Feb 2017
    Location
    Sydney, NSW, Australia
    Posts
    12

    Default

    Thankyou. Any auto electrician recommendations in Sydney?

    Sent from my SM-G900I using aussiefrogs mobile app

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •