2008 Pug 407 2.0 Diesel auto Sedan doing strange things
  • Register
  • Help
Results 1 to 6 of 6
Like Tree2Likes
  • 2 Post By dcc236

Thread: 2008 Pug 407 2.0 Diesel auto Sedan doing strange things

  1. #1
    Fellow Frogger!
    Join Date
    Oct 2014
    Location
    Brisbane/Australia
    Posts
    335

    Default 2008 Pug 407 2.0 Diesel auto Sedan doing strange things

    I think I am cursed. I recently had a bunch of issues with our 2007 Pug 407 wagon after I stupidly incorrectly installed its battery after an overnight charge. Within days of having the wagon running beautifully, our 2008 407 sedan has decided to play silly buggers.

    Advertisement


    The sedan has given us next to no issues until the last week. I recently installed a new battery in it (about a month ago). It had one of its usual services at the same time - new air filter, oil filter, cabin filter, diesel filter, oil change and new tyres.

    Late last week on every drive it would throw up all sorts of errors but continue to drive nicely, as it always has. In sequence - the radio would cut in and out, the LCD display would flash on and off in sequence with the radio playing up, we then get an air bag error on the centre LCD in the dash, abs error, esp error, rear parking sensor error, the errors eventually all disappear, the reverse sensors do not work and the radio seems to power off for a 1/4 sec and then comes back to life regularly.

    I have put the battery on the charger but the errors are the same the next day.

    Lexia isn't much help.

    Is my sedan possessed or am I just jinxed?

    Wife wants me to get rid of both Pugs and get a couple of "decent" cars. I think she liked our Audi's better. It doesn't help that the air cond is not working in both 407's.

    Help before I am forced to ditch both diesel 407's for something impractical like an Audi S4/RS4 and a Q5 for her.
    Last edited by dcc236; 13th March 2018 at 04:32 PM. Reason: I can't spell

  2. #2
    1000+ Posts
    Join Date
    Jun 2013
    Location
    Sydney
    Posts
    7,479

    Default

    If your wife thinks an Audi is a great improvement, ie decent, I think she'll find that Mr Bosch electrifies both engines.

    I have seen this insane behaviour in Pugs, but so far not from a 407. It was caused by improper battery disconnection/reconnection, which unfortunately happened to you. If the code is really screwed, beyond Diagbox resets, a software reload (dealer, unfortunately) may do the trick.

  3. #3
    Fellow Frogger! Roland's Avatar
    Join Date
    May 2005
    Location
    Perth
    Posts
    693

    Default

    In addition to what seasink has posted -

    Have you checked the alternator output?

    Cheers
    Roland
    Land Rover Discovery 4
    406 Coupe D9 - Manual (2002)
    307 Hdi Estate - Auto - (2007)
    307 Hdi Sedan - Auto - (2007)
    505GR Estate - Personal Import from UK 1971cc Manual (March 1986)
    405 Mi16x4 (all the parts ready to install into the LeMans body)

  4. #4
    1000+ Posts robmac's Avatar
    Join Date
    Nov 2004
    Location
    Melbourne / Caulfield
    Posts
    17,440

    Default

    Help before I am forced to ditch both diesel 407's for something impractical like an Audi S4/RS4 and a Q5 for her.
    A family member has just purchased a SQ5 Quatro. I can confirm it is beautiful car to drive and has blistering performance.

    After an extended drive, I can even overlook the fact it is a diesel.

    There nothing impractical about the SQ5 Quatro.
    Mutual Respect is Contagious


  5. #5
    Fellow Frogger! dmccurtayne's Avatar
    Join Date
    Jul 2013
    Location
    Newcastle/ central coast
    Posts
    418

    Default

    Sounds like alternator over charging

  6. #6
    Fellow Frogger!
    Join Date
    Oct 2014
    Location
    Brisbane/Australia
    Posts
    335

    Default

    Looks like a BSI reset has fixed it.
    Armidillo and dimistyle like this.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •