Weird Brake problem 307 cc
  • Register
  • Help
Results 1 to 9 of 9
Like Tree1Likes
  • 1 Post By gromzx

Thread: Weird Brake problem 307 cc

  1. #1
    Tadpole
    Join Date
    Nov 2015
    Location
    Melbourne
    Posts
    10

    Default Weird Brake problem 307 cc

    Hi All,
    I had a strange thing happen in my auto 307 cc. My wife was in the car with it parked on a slight incline with the engine running for about 50 minutes, when she went to drive off the brake pedal was really hard and the brakes were locked on. Could barely move the car due to the brakes being on.

    Had to leave the car overnight and the next day the car was fine and has been since.

    Has this sort of thing ever happened to anyone else?

    Cheers,
    Tim

    Advertisement

  2. #2
    COL
    COL is offline
    A110 COL's Avatar
    Join Date
    Mar 2002
    Location
    Van Diemen's Land
    Posts
    4,145

    Default

    Sounds like the brakes where hydraulically locked on for some reason.

    Maybe something went amiss in the master cylinder.

    Don't suppose you can replicate the situation?
    Regards Col

    1973 Renault R12 Station Wagon
    1976 Renault R12 Station Wagon
    2002 Renault Laguna V6
    1973 Alpine A110

    http://alpine-a110.weebly.com/

  3. #3
    Fellow Frogger! gromzx's Avatar
    Join Date
    May 2011
    Location
    melborne
    Posts
    364

    Default

    Sounds like a faulty valve in the brake booster. Once the vacuum bled out over night it released.
    Roland likes this.

  4. #4
    Fellow Frogger!
    Join Date
    Nov 2010
    Location
    Melbourne
    Posts
    158

    Default

    I worked with a person that had a C2 Citroen that would do similar things and it took ages to find . Turned out to be a multipin connector behind the brake booster that would apply full brakes if the circuit was broken . once this was secured to not come loose by a cable tie around both parts of the plug it never happened again . His would apply full brakes randomly when he was driving as well !! Good luck

  5. #5
    Tadpole
    Join Date
    Nov 2015
    Location
    Melbourne
    Posts
    10

    Default

    I will have a look around the booster on the weekend and see what I can find. I plugged lexia into it and did not get any faults for it

    Sent from my SM-G900I using Tapatalk

  6. #6
    Fellow Frogger! Roland's Avatar
    Join Date
    May 2005
    Location
    Perth
    Posts
    727

    Default

    Quote Originally Posted by timbo-73 View Post
    Hi All,
    I had a strange thing happen in my auto 307 cc. My wife was in the car with it parked on a slight incline with the engine running for about 50 minutes, when she went to drive off the brake pedal was really hard and the brakes were locked on. Could barely move the car due to the brakes being on.

    Had to leave the car overnight and the next day the car was fine and has been since.

    Has this sort of thing ever happened to anyone else?

    Cheers,
    Tim
    Sorry to ask but what was it doing, "parked on a slight incline with the engine running for about 50 minutes"?
    Land Rover Discovery 4
    406 Coupe D9 - Manual (2002)
    307 Hdi Estate - Auto - (2007)
    307 Hdi Sedan - Auto - (2007)
    505GR Estate - Personal Import from UK 1971cc Manual (March 1986)
    405 Mi16x4 (all the parts ready to install into the LeMans body)

  7. #7
    Tadpole
    Join Date
    Nov 2015
    Location
    Melbourne
    Posts
    10

    Default

    My wife sitting in the car talking to her friend when she was dropping her off.. apparently it felt like they were only talking for a couple of minutes.....

  8. #8
    sans witticism SLC206's Avatar
    Join Date
    Sep 2003
    Location
    North Parramatta
    Posts
    3,997

    Default

    So is it safe to assume it was in Park or Neutral, with the handbrake on the whole time?
    Regards,

    Simon

    2018 308 GTi 2011 DS3 DSport
    ----
    2014 208 GTi 2007 207 GTi 2004 206 GTi180 2000 206 GTi 1995 306 XT

    www.peugeotclub.asn.au

  9. #9
    Tadpole
    Join Date
    Nov 2015
    Location
    Melbourne
    Posts
    10

    Default

    It was in park with the handbrake on. Really strange fault...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •