Peugeot 207 gti
  • Register
  • Help
Results 1 to 4 of 4

Thread: Peugeot 207 gti

  1. #1
    AAA
    AAA is offline
    Member AAA's Avatar
    Join Date
    Nov 2016
    Location
    Australia
    Posts
    67

    Default Peugeot 207 gti

    Hi everyone I'm hope someone can help me I'm having problem with my Peugeot 207 gti turbocharger not enough boost it feels like driving a normal car engine. I took it to mechanic to get it diagnosed and there no error code that came up. I have change the electrovalve to GFB dv+ and still no boost ???? Has anyone have this problem before???

    Regards
    Tee


    Sent from my iPhone using aussiefrogs

    Advertisement
    Last edited by AAA; 5th November 2016 at 01:03 PM.

  2. #2
    Member
    Join Date
    Jan 2015
    Location
    ACT
    Posts
    62

    Default

    I have the same issue, currently looking into the electrovalves

  3. #3
    Fellow Frogger!
    Join Date
    Feb 2016
    Location
    Sydney
    Posts
    182

    Default

    Sounds expensive...
    Currently:
    Mazda MX-5 (my third and the third generation NC).
    Lazily looking for a 205 daily driver.
    Previously:
    Peugeot 206, Peugeot 205, Honda CR-Z, BMW 3-Series (2), Audi A4 (2), BMW Z3, Mazda MX-5 (2), Saab 900, Morris Mini, Mazda 121, Nissan Pulsar and Holden Gemini.

  4. #4
    AAA
    AAA is offline
    Member AAA's Avatar
    Join Date
    Nov 2016
    Location
    Australia
    Posts
    67

    Default

    Hi mechanic found out one of the pipe disconnected that's why it didn't have any boost. They put it back n tighten all the pipe n boost is back to normal


    Sent from my iPhone using aussiefrogs

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •