@#$#%$# Electric windows
  • Register
  • Help
Results 1 to 10 of 10
  1. #1
    Member
    Join Date
    Aug 2002
    Location
    NSW
    Posts
    79

    @#$#%$# Electric windows

    my 405 Mi16 drivers window mechanism is stuffed. It operates up but not down. pulled it out the other day and the down cable seems to be binding in the winch mechanism. Anyone got a fix or do I ditch it and get a new one? Regards Greg

    Advertisement

  2. #2
    Guru davemcbean's Avatar
    Join Date
    Apr 2001
    Location
    Camden NSW & Selwyn NZ
    Posts
    2,334
    GregS:
    down cable seems to be binding in the winch mechanism.
    You have to be kidding! Does the 405 really use a cable and winch system?

    I thought Peugeot got rid of these horrible things when they went from the series 1 504 coupe/carbiolet to the series 2 in late 1974, when they implemented the much superior pinion and sector system. I can't believe they went back to an antiquated cable and winch system for the 405 in the late 1980s. That's really weird! eek!

    Dave

    <small>[ 04 September 2003, 11:40 AM: Message edited by: davemcbean ]</small>
    NZ Fleet
    1976 504 Ti
    1984 205 GT twin carb
    1991 205 SI 1.6GTI motor
    1994 106 Xsi
    1996 Mondeo V6
    Aus Fleet
    1955 203C
    1997 Civic Cxi (great allrounder- revy, flexible, nimble, comfortable , economical, simple and durable )

  3. #3
    Member
    Join Date
    Jun 2003
    Location
    Griffith
    Posts
    43
    I had both these problems

    one problem was simply a case of the switch not working properly... i drowned it in wd40 and now it works right :-)

    2ndly a window winder thing, I beleive its a cable operated thing, it broke and wouldn't come up, it cost me a few hundred for someone else to fix it :-) might be worth taking the skins off and checking that the cable and all hasn;t fallen off the pullies, a bit of wd on the pullies may do something. i have some haynse manual in pdf format, e-mail me and i can arrange for a copy of it for ya..

    good luck peugeot_

    <small>[ 04 September 2003, 09:03 PM: Message edited by: spamboy ]</small>

  4. #4
    Member
    Join Date
    Aug 2002
    Location
    NSW
    Posts
    79
    thanks for the feedback spamboy. Ive had it out and the cable is definitely jammed in the winch/winder thingy. looks like a new one is needed. It costs around $300 but summers coming so I'll bite the bullet. greg

  5. #5
    Member
    Join Date
    Jun 2003
    Location
    Griffith
    Posts
    43
    mine managed to get stuck in teh down position :-)

    if your going to take it in for repairs, try having a crack at it your self, bit of force may get something out and working...

    cheers
    Nathan

  6. #6
    UFO
    UFO is offline
    CitroŽn Tragic UFO's Avatar
    Join Date
    Aug 2001
    Location
    Gerringong, NSW, Australia
    Posts
    9,738
    Greg

    Sounds like your Pug has the same sort of mechanism that Cit XMs have. Unusual though, because the BX has the pinion and sector like Dave Mc refers to.

    The same prob has happened with early XMs and I am hoping it never happens with later ones.

    You might do well doing a search on <a href="http://autos.groups.yahoo.com/group/XM-L/" target="_blank">Yahoo XM List</a> to see if you can find if anyone came up with a fix.

    When you get to the XM List, click Messages on the left, then use Search on the right of the screen to start your searching.
    Craig K
    2009 C5 HDi Exclusive

  7. #7
    UFO
    UFO is offline
    CitroŽn Tragic UFO's Avatar
    Join Date
    Aug 2001
    Location
    Gerringong, NSW, Australia
    Posts
    9,738
    Actually, check message number 24024. Someone has just posted some tips today! dance
    Craig K
    2009 C5 HDi Exclusive

  8. #8
    UFO
    UFO is offline
    CitroŽn Tragic UFO's Avatar
    Join Date
    Aug 2001
    Location
    Gerringong, NSW, Australia
    Posts
    9,738
    Or try this:

    <a href="http://www.andyspares.com/discussionforum/topic.asp?TOPIC_ID=3246" target="_blank">Andy Spares Forum</a> citroen_ dance
    Craig K
    2009 C5 HDi Exclusive

  9. #9
    Member
    Join Date
    Aug 2002
    Location
    NSW
    Posts
    79
    Thanks UFO for the help. Ill give it another go this weekend. greg

  10. #10
    sans witticism SLC206's Avatar
    Join Date
    Sep 2003
    Location
    North Parramatta
    Posts
    3,997
    UFO:
    Greg

    Sounds like your Pug has the same sort of mechanism that Cit XMs have. Unusual though, because the BX has the pinion and sector like Dave Mc refers to.

    The same prob has happened with early XMs and I am hoping it never happens with later ones.
    And oh what fun they are to play with. I spent a few hours fixing a rear window on an XM a few weeks ago. All because of a dodgy plastic clip.

    On another note, I had the door trim off my 206 GTi the other day, and I'm pretty sure I saw the same cable arrangement there. There weren't too many holes to look through mind you so I could have been wrong blush
    Regards,

    Simon

    2018 308 GTi 2011 DS3 DSport
    ----
    2014 208 GTi 2007 207 GTi 2004 206 GTi180 2000 206 GTi 1995 306 XT

    www.peugeotclub.asn.au

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •