2001 306 Dash Light issues
  • Register
  • Help
Results 1 to 8 of 8
  1. #1
    Fellow Frogger!
    Join Date
    May 2012
    Location
    Brisbane
    Posts
    140

    Default 2001 306 Dash Light issues

    dash lights - lamp for fuel light went out a while (1-2yrs) ago - occasionally comes on for a bit (rare) and then off, but mostly off

    now the dash lights come on for a bit on first start, flash/flicker a few times and then go off within a minute or so and then they stay off until a restart

    any ideas? sounds like a dodgy wire connection, but where?

    Advertisement


    thank you

    ALW

  2. #2
    Fellow Frogger!
    Join Date
    May 2012
    Location
    Brisbane
    Posts
    140

    Default

    lights worked for the last week and now gone again

    haven't pulled anything apart yet (presumably getting to plug connecters requires the instrument binnacle out) , but nobody had this before?

  3. #3
    Fellow Frogger!
    Join Date
    Mar 2011
    Location
    Melbourne
    Posts
    413

    Default

    ALL warning lights? Say, even the foglamps and battery discharge? Indicators? Sounds like an odd problem if they suddenly work again when turning the car off then on again. Perhaps a crossed wire somewhere that's causing them to only come on during a certain startup routine.
    2000 306 GTi6 'Josie'

  4. #4
    Fellow Frogger!
    Join Date
    May 2012
    Location
    Brisbane
    Posts
    140

    Default

    I'll have to check more carefully - drove the car the other night and no lights for any instruments (speedo, tacho, fuel etc) - can't recall if the ignition light came on on start up - don't think that headlights light either came on

    and this time it didn't light up on restart - dead as a dodo

  5. #5
    1000+ Posts Peter C's Avatar
    Join Date
    Aug 2004
    Location
    SWOTR
    Posts
    3,657

    Default

    An earth? Dry joint?

  6. #6
    Fellow Frogger!
    Join Date
    May 2012
    Location
    Brisbane
    Posts
    140

    Default

    yes, good thought, but where does one look?

  7. #7
    Fellow Frogger!
    Join Date
    May 2012
    Location
    Brisbane
    Posts
    140

    Default

    now have the instrument binnacle out - that was fun

    looks like I have failing bulbs, I guess to be expected after 15yrs

    will replace them all tomorrow and see how we go

  8. #8
    Fellow Frogger!
    Join Date
    May 2012
    Location
    Brisbane
    Posts
    140

    Default

    and confirmed - seems when the bulbs go they continue to arc for a bit and then die

    I've replaced all 24 but annoys me I had to buy 6 from Supercheap (due to limited supply elsewhere) and 1 out of the packet was faulty - gonna take the 6 back as they look cheap and I don't want to be pulling the binnacle out on a regular basis

    although, I am quick at it now - at least once I used YouTube to show me how to unclip the rear electrical plugs

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •