Mi16, Xu9 Redline Dizzy Explosion
  • Register
  • Help
Results 1 to 5 of 5
Like Tree1Likes
  • 1 Post By bowie

Thread: Mi16, Xu9 Redline Dizzy Explosion

  1. #1
    1000+ Posts bowie's Avatar
    Join Date
    Aug 2002
    Location
    Sydney, Concord City, Sir.
    Posts
    3,449

    Default Mi16, Xu9 Redline Dizzy Explosion

    Mi16, Xu9 Redline Dizzy Explosion-pxk56438.jpg
    Mi16, Xu9 Redline Dizzy Explosion-pxk56426.jpg

    Advertisement


    Don't do burn outs kids.

    Works: 2003 YV Commodore (That is Cecil to you)
    Playing: R12, SuperPos, thinks It's a race car and Sunny the R12 Lego set.
    Previous: SuperGrumpy fuel spitting 504ti(ish), SuperComfortable 505 STI, SuperDoper carried my groceries Mi16, Choo Choo'd Volvo S40
    Wanted Will hoard 12/15/17 Junk.

    "More and more of less and less" - Marina Abramović

  2. #2
    Fellow Frogger! Grey_Lover's Avatar
    Join Date
    Sep 2015
    Location
    Mornington Peninsula
    Posts
    144

    Default

    What happened ? Shaft break ?
    206 gti 180
    306 gti 6
    fx holden historic race car

  3. #3
    1000+ Posts bowie's Avatar
    Join Date
    Aug 2002
    Location
    Sydney, Concord City, Sir.
    Posts
    3,449

    Default

    So what really happened? Not sure..

    Car died on me on the way home one day, quick look and there was a hole (pictured above). Thank you EAI for having a new cap in stock, I head out this afternoon and of course it starts to rain.. (grumble grumble)

    Working quickly I remove everything and armed with a can of WD40 I keep most of the ignition system dry(ish)

    It's all back together now, back in the car.

    Rrararararararararararararararararararar clunk.
    Rararararararararararararararararararar clunk

    "Hmmmm" I think to myself.

    Back out, hood up, only raining slightly now, something shiny catches my eye.
    "Is that.. Is that the, why is that there?

    The rotor was sitting there on a heater hose. I've just been trying to start a car without a rotor..

    "Wait, how the heck did that come off?"

    A quick inspection confirms 1 screw is AWOL and there is damage to one side, looks like it has been burnt.

    So I'm assuming it has come undone under the cap, and the rotor flange them mashed it into the side of the cap thus exploding like pictured above. Is that a thing! Rotors coming undone? It was a miracle the rotor was't ejected completely out of the car when it came grinding to a halt the other night..

    Of course in all excitement its still raining and I've now lost one of the cap retaining bolts. Great, 2/3 cap bolts, 2/3 rotor screws...

    I managed to fire it up (after correcting the firing order #fail) and it idled better then it ever has. I nurse it home and all is well. Here's hoping EAI have the rest of the system now..
    Grey_Lover likes this.

    Works: 2003 YV Commodore (That is Cecil to you)
    Playing: R12, SuperPos, thinks It's a race car and Sunny the R12 Lego set.
    Previous: SuperGrumpy fuel spitting 504ti(ish), SuperComfortable 505 STI, SuperDoper carried my groceries Mi16, Choo Choo'd Volvo S40
    Wanted Will hoard 12/15/17 Junk.

    "More and more of less and less" - Marina Abramović

  4. #4
    1000+ Posts bowie's Avatar
    Join Date
    Aug 2002
    Location
    Sydney, Concord City, Sir.
    Posts
    3,449

    Default

    Yaaaaaaaaaaaaah Tthey had a rotor in stock, and it comes with mounting screws. AND it will be delivered today!

    Well that's all my good luck taken care of for 2016.

    Works: 2003 YV Commodore (That is Cecil to you)
    Playing: R12, SuperPos, thinks It's a race car and Sunny the R12 Lego set.
    Previous: SuperGrumpy fuel spitting 504ti(ish), SuperComfortable 505 STI, SuperDoper carried my groceries Mi16, Choo Choo'd Volvo S40
    Wanted Will hoard 12/15/17 Junk.

    "More and more of less and less" - Marina Abramović

  5. #5
    Fellow Frogger! Balki's Avatar
    Join Date
    Nov 2010
    Location
    Sheffield/Tasmania
    Posts
    628

    Default

    I have seen that happen before, found the rotor botton was loose, if you look closely the original rotor button bolts have blue locktite on the treads so I put a little on the treads again but not to much

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •