Radio mystery
  • Register
  • Help
Results 1 to 4 of 4

Thread: Radio mystery

  1. #1
    Member Napoleon's Avatar
    Join Date
    May 2012
    Location
    Hobart
    Posts
    36

    Default Radio mystery

    2003 Peugeot 406 Coupe. Radio works on AM & FM when ignition switched on accessory mode. When ignition is switched on fully (start and run) the car the radio only works on FM mode. In other words if I want to listen to AM, I have to park the car. This appears to me even more of a mystery than the meaning of life. Has anybody experienced this problem and if so what is the fix - please?

    Advertisement

  2. #2
    1000+ Posts
    Join Date
    Dec 2005
    Location
    HOBART
    Posts
    1,265

    Default

    Peter, my thoughts are along the lines of the ignition switch. Another fault generated by new technology, not found in earlier cars.
    If this is the case, unless the switch can be cleaned, the only solution is to replace it.
    1998 Peugeot 406 D8SV Manual
    1999 Peugeot 406 D8ST Auto
    2002 Peugeot 406 D9SV Manual
    1994 Peuegot 306 N3 Cabriolet Manual
    1994 Peugeot 306 XR N3 Hatch
    1995 Peugeot 505 GTI executive
    1976 Peugeot 504 Sedan - Now sold

    Over 60 Pugs in my time
    Gerry Mullock

  3. #3
    Fellow Frogger!
    Join Date
    Oct 2012
    Location
    Armadale, Melbourne
    Posts
    255

    Default

    Just a thought, does the 406 coupe have a proper aerial or an in glass one? My volvo 850 wagon lost FM but turned out it was a defective signal booster for the aerial conveniently located in the rear side window.

  4. #4
    1000+ Posts Fordman's Avatar
    Join Date
    May 2004
    Location
    Perth/West Australia
    Posts
    1,445

    Default

    Quote Originally Posted by dave_R16TS View Post
    Just a thought, does the 406 coupe have a proper aerial or an in glass one? My volvo 850 wagon lost FM but turned out it was a defective signal booster for the aerial conveniently located in the rear side window.
    My thoughts also. If it has an aerial booster, it may be getting power feed with Accessories but not when the ignition switch is in Run position. Whereas if the radio is working on FM only, then at least it must be getting power from the ignition switch in Run position.
    2004 Scenic I 2.0 auto (Hers)
    2016 Ford Territory (His)
    2004 WRX (Sunday car)

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •