Help a 306 in need.
  • Register
  • Help
Results 1 to 10 of 10
  1. #1
    Fellow Frogger! crosspug's Avatar
    Join Date
    Nov 2001
    Location
    Newcastle, NSW, Australia
    Posts
    547

    Help a 306 in need.

    Hi all

    My mums 306XT 1999 Auto has started dieing going around corners again as well as stopping at traffic lights.
    This happened about 1.5 years ago when it died going around right hand turns, went back to the dealer and they said (after ages!) that it was the MAP board which they replaced.
    It has run fine until now. Died 3 times in one little drive to the next suburb.

    Also has a strong smell of petrol in the cabin.

    Any ideas?? Its going in on Monday to the dealer but thought someone might have an idea of what it is.

    Advertisement


    Jon Cross
    1989 BX16Valve

    "Resting" 1983 505 STi

  2. #2
    Too many posts! JohnW's Avatar
    Join Date
    Jul 2001
    Location
    Perth, WA, Australia
    Posts
    10,944
    Jon,

    Ours (1995 XT)did "the occasional stopping for no reason thing" when it was new.

    No clear answer from dealer but I seem to remember they needed to tighten up a connection on the rail that supplies fuel to the injectors. Ours definitely leaked fuel (the dealer alleged coolant!).

    They also reset the computer. It hasn't done anything like it for more than 6 years!

    Good luck - I'll be interested to hear how you get on.

    JohnW
    JohnW

    Renault 4CV 1951
    Renault R8 1965
    Renault Scenic 2005 (wife's)
    Renault Scenic 2007 (mine)
    Renault Scenic 2006 (daughter's)
    CitroŽn CX Pallas 1980

    National Co-ordinator, Renault 4CV Register of Australia

  3. #3
    Fellow Frogger! MYT205's Avatar
    Join Date
    Sep 2001
    Location
    NSW
    Posts
    1,063
    Our 99 GTi6 did the same thing a couple of times about 6 months ago. Dealer couldn't find the fault but replaced a few things and hasn't occurred since.

    I think its just one of those Peugeot quirks.

  4. #4
    rek
    rek is offline
    1000+ Posts rek's Avatar
    Join Date
    Aug 2001
    Location
    Melbourne, Vic
    Posts
    1,388
    Funny you all mention this. As of few thousand k's ago, my 306 very occasionally stutters and hesitates when accelerating from rest.

    Usually pushing in the clutch and giving it a good rev gets things back again and the problem goes away for a day or two.

    Not all that serious (yet), though my car's due for a mid-service check up in 2000 k's or so; I'll see what the service people have to say about it.
    Peter
    2008 Saab 9-3 1.9 TiD Sportcombi
    2011 Volvo C30 DRIVe 1.6D

  5. #5
    Fellow Frogger!
    Join Date
    Sep 2001
    Posts
    490
    hmm... from what people have said in here, it sounds like the leaky fuel hose connection is the best diagnosis. Crosspug are there any signs of leaks once it conks out and you look under the bonnet?

    Incidentally, my Gti6 very occassionally feels weird when I start it up in cold weather and start driving immediately (alway slowly, to let it warm up.) Once I get off the gas to change to second gear, the revs drop and it feels like it's dieing when I try to accelerate again. I just coast for a bit in gear, and then the problem's gone. Only happens occasionally, maybe it's the idle stepper motor on it's way out.

  6. #6
    Fellow Frogger!
    Join Date
    Sep 2001
    Posts
    490
    Also, not sure if this will help but my car (97 model) feels much better having added Nulon total fuel system cleaner. Infinitely better infact - better acceleration, far smoother and more responsive. It wasn't enjoying the 6500rpm + zone previously.

    I wonder if the injectors are a bit clogged, or the fuel pump is on its way out.

  7. #7
    Fellow Frogger!
    Join Date
    Feb 2001
    Location
    Sydney
    Posts
    493
    Mine has died a few times but i don't smell fuel and i think its related to my stepper motor. Mines a 98 306 xsi and i've ordered a new stepper motor. Just waiting for a friend to pick it up for me from parra as i don't want to take any time off work just for a part! I hope it fixes my problem!

  8. #8
    Budding Architect ???? pugrambo's Avatar
    Join Date
    Jul 2000
    Location
    Parkes - N.S.W - Australia - Earth
    Posts
    12,266
    there was a recall on 306's for a fuel line on the rail
    make sure this has been done on your cars
    apparently it was 5/16 instead of 1/4"
    it is only a very short hose but still worth checking
    mine was done as soon as i got the letter from peugeot about it
    3 x '78 604 SL

    1 x 2018 3008

    1 x 2000 Citroen XM,

    1 x '98 306 GTi6 sadly sold

    1 x secret project

    1 x '98 406 STDT troop carrier and i don't care if it stinks, i don't sniff it's arse Death by wank tank

    1 x '99 406SV 5spd wagon, time to burn more fuel

    1 x 1994 605 SV3.0

  9. #9
    Fellow Frogger! crosspug's Avatar
    Join Date
    Nov 2001
    Location
    Newcastle, NSW, Australia
    Posts
    547
    Hi all

    thanks for the info.

    Turns out that the MAP sensor was bung again. Second time in 2 years that it has been replaced. The car runs a hell of a lot better now. Just glad that its under warranty.

    Thanks again

    Jono
    1989 BX16Valve

    "Resting" 1983 505 STi

  10. #10
    Tadpole
    Join Date
    Mar 2002
    Location
    Sydney
    Posts
    2
    I can only think of the obvious cause that you could have some kind of problem with your fuel supply such as a blockage somewhere, causing the fuel to cut out when you go round corners. Or something could be pressing on or interfering with the flow of fuel to the engine, so that it is leaking out causing the smell in the cabin.
    Probably not much help.
    Rog306.
    Roger306

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •