fuel sender unit 405mi16 series 1
  • Register
  • Help
Results 1 to 8 of 8
  1. #1
    Fellow Frogger!
    Join Date
    Nov 2010
    Location
    Melbourne
    Posts
    154

    Default fuel sender unit 405mi16 series 1

    Are these sender units known to give problems and are they fairly to change over

    Advertisement

  2. #2
    Member
    Join Date
    Mar 2014
    Location
    Melbourne
    Posts
    108

    Default

    Whats the issue exactly?

  3. #3
    Fellow Frogger!
    Join Date
    Nov 2010
    Location
    Melbourne
    Posts
    154

    Default

    the fuel gauge has started to read incorrectly . When it shows 1/4 full only takes 30 litres to refill . At full needle is down a little from the full line .It was not like this until recently

  4. #4
    Member
    Join Date
    Mar 2014
    Location
    Melbourne
    Posts
    108

    Default

    before ripping out the back seats and fuel sender in the tank, would recommend checking earths which are located (painfully) behind the front bumper - there is one on the left and right. Also check the one under the battery tray (also painful). The aluminium rivet holding the two pieces together corrodes resulting in bad earth connections between the two sides which come together. It's likely the plug is also full of grit/grime. Virtually every earth from the engine management comes to this point then goes back to chassis/battery.

    Check these first, get the WD40 and an old toothbrush out and go crazy. See if this works first.

    Geoff

  5. #5
    Fellow Frogger!
    Join Date
    Nov 2010
    Location
    Melbourne
    Posts
    154

    Default

    Thanks Geoff I will check these out when I get a chance . Can I get to these points from underneath with the front bumper still on the car . Is the earth under the battery tray a strap from the -ve terminal of the battery . If so I have upgraded this a while back with very large straps

  6. #6
    Fellow Frogger!
    Join Date
    Nov 2010
    Location
    Melbourne
    Posts
    154

    Default

    Cannot locate the earths Geoff is referring to . The only earth connection I have found is 4 wires terminating at the front of the drivers side mudguard . Faulty earth could the cause of a few niggles the car has so if any one can help me locate these other connections I would be most appreciative

    Keith

  7. #7
    Member
    Join Date
    Mar 2014
    Location
    Melbourne
    Posts
    108

    Default

    Earths are big cream blocks with yellow plugs with green/yellow stripe wires. Pics of the ones either side of the thermos behind the front bumper (you need to remove the front bumper) and also the one shown under the battery tray (need to remove the battery and battery tray).
    fuel sender unit 405mi16 series 1-img_3896.jpgfuel sender unit 405mi16 series 1-image1.jpg

  8. #8
    Fellow Frogger!
    Join Date
    Nov 2010
    Location
    Melbourne
    Posts
    154

    Default

    Thanks Geoff , when I find time I will check these out . Its a pity that most things are so hard to get to on such a good car . Just have to put up with that as they are so good . Thanks for the photos .

    Keith

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •