N5 306 Service indicator (spanner) came on suddenly
  • Register
  • Help
Results 1 to 3 of 3
  1. #1
    Fellow Frogger!
    Join Date
    Dec 2012
    Location
    Melbourne
    Posts
    187

    Default N5 306 Service indicator (spanner) came on suddenly

    Hi all,

    My 306's service indicator kms suddenly went from around 6000 to 0 and the spanner is on. I reset it myself each time after I change the oil (it usually only gets to 4-5 thousand before I change it anyway).

    Advertisement


    No warning lights or anything else have come on and it's just about to tick over 190,000 kms. Haven't disconnected the battery in ages either.

    A glitch? Or should I be concerned?

    Cheers,

    Bernie
    1998 N5 306 XSi

  2. #2
    Fellow Frogger! gromzx's Avatar
    Join Date
    May 2011
    Location
    melborne
    Posts
    364

    Default

    Has it been a long time since the last service?
    I have never confirmed this, but I'm told that if a certain amount of time has passed since the last service (eg 12 month) then the service counter will go to zero.

  3. #3
    Fellow Frogger!
    Join Date
    Dec 2012
    Location
    Melbourne
    Posts
    187

    Default

    I last changed the oil about September/October last year. I guess that is about 6 months, which after a bit of digging on Google, is the recommended service interval for pre-1999 Peugeots.

    Still, I'm sure I've gone more than 6 months without servicing and this didn't happen...
    1998 N5 306 XSi

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •