Service message on dash ???
  • Register
  • Help
Results 1 to 5 of 5
  1. #1
    Fellow Frogger! mmm...CORNERS's Avatar
    Join Date
    Jan 2004
    Location
    Epping, Sydney
    Posts
    574

    Default Service message on dash ???

    Hi all, heres a simple question for you, my odometer display (N5 306 1.8) is now showing a flashing -0 upon start up and the spanner symbol is continuously on, is this just the car asking for service??? It's only been 6,000 klicks since the last one. The cars got 67,000kms now, should I be changing the timing belt with the next service? woops, thats 2 questions!

    thanks

    Advertisement

  2. #2
    Banned orestes's Avatar
    Join Date
    Mar 2004
    Location
    Sunshine Coast
    Posts
    4,520

    Default

    not sure whats going on witrh your odometer, but you should be looking to change your timeing belt at around 80-100000 km's

  3. #3
    1000+ Posts kermit's Avatar
    Join Date
    Jun 2002
    Location
    Inner city, Brisbane
    Posts
    2,335

    Default

    Quote Originally Posted by mmm...CORNERS
    Hi all, heres a simple question for you, my odometer display (N5 306 1.8) is now showing a flashing -0 upon start up and the spanner symbol is continuously on, is this just the car asking for service??? It's only been 6,000 klicks since the last one. The cars got 67,000kms now, should I be changing the timing belt with the next service? woops, thats 2 questions!

    thanks
    A flashing zero does indicate it is time for a service. If your service indicator was reset by the dealer at the last service then maybe something else is amiss. Maybe it wasn't reset at the last service? Best to get it checked out.

    As for the timing belt, these are due for change at 80k or 4 years. This is one part you don't want to fail.
    Cheers Simon
    >8-]

    Rendezvous Adelaide 2005

    Polo Green '01 406 Coupe (5spd Man)
    Tuscany Green '00 206 GTi (Croaked!)

    My Flickr Photos

    206gti.net
    peugeot-206gti
    peugeot-307
    peugeot-407
    peugeotclub.asn.au

  4. #4
    Budding Architect ???? pugrambo's Avatar
    Join Date
    Jul 2000
    Location
    Parkes - N.S.W - Australia - Earth
    Posts
    12,266

    Default

    the service mileage can be set for a couple of different mileages

    i'd say your dealer has set yours at 6k instead in the normal 10k

    it tells you in the handbook how to change it

    if you don't have a handbook let me know as i have the complete thing scanned and sitting in my yahoo briefcase which you are free to have access to
    3 x '78 604 SL

    1 x 2018 3008

    1 x 2000 Citroen XM,

    1 x '98 306 GTi6 sadly sold

    1 x secret project

    1 x '98 406 STDT troop carrier and i don't care if it stinks, i don't sniff it's arse Death by wank tank

    1 x '99 406SV 5spd wagon, time to burn more fuel

    1 x 1994 605 SV3.0

  5. #5
    Fellow Frogger! mmm...CORNERS's Avatar
    Join Date
    Jan 2004
    Location
    Epping, Sydney
    Posts
    574

    Default

    Quote Originally Posted by kermit
    A flashing zero does indicate it is time for a service. If your service indicator was reset by the dealer at the last service then maybe something else is amiss. Maybe it wasn't reset at the last service? Best to get it checked out.

    As for the timing belt, these are due for change at 80k or 4 years. This is one part you don't want to fail.
    cool, i was hoping that a flashing zero didnt mean "engine will now self destruct in 5, 4, 3, 2, ".....

    I was waiting until i hit 70,000km's before my next service, but i'll get it looked at earlier

    cheers!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •