406 2003 Multi-function display
  • Register
  • Help
Results 1 to 4 of 4
  1. #1
    Fellow Frogger! andrepug's Avatar
    Join Date
    Aug 2004
    Location
    Victoria
    Posts
    454

    Icon5 406 2003 Multi-function display

    Just reset the clock and date after having the battery disconnected for a day but can't get the range, fuel consumption, average speed etc to display. It showed up before but there must be some extra step needed to turn it back on. Any ideas please?

    Advertisement

  2. #2
    1000+ Posts cav91's Avatar
    Join Date
    Nov 2010
    Location
    Romsey, VIC
    Posts
    2,329

    Default

    Usually you need to drive for a few kms before it will display

    Via the aussiefrogs App
    2011 Renault Koleos manual petrol, yes it's boring, but not as boring as:
    2017 Renault Koleos auto

  3. #3
    Fellow Frogger! andrepug's Avatar
    Join Date
    Aug 2004
    Location
    Victoria
    Posts
    454

    Default

    that's what I expected but nothing shows after a trip from Bright to Melbourne

  4. #4
    1000+ Posts cav91's Avatar
    Join Date
    Nov 2010
    Location
    Romsey, VIC
    Posts
    2,329

    Default

    Only other thought is to give it a go of resetting. You probably already have! If you haven't it will reset itself if you hold the button in the end of the wiper switch.

    Via the aussiefrogs App
    2011 Renault Koleos manual petrol, yes it's boring, but not as boring as:
    2017 Renault Koleos auto

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •