306 XT clicking noise (relay??)
  • Register
  • Help
Results 1 to 5 of 5
  1. #1
    Member
    Join Date
    Nov 2003
    Posts
    59

    Default 306 XT clicking noise (relay??)

    Hiyas,

    Newbie question time again My 98 306 has just started making a strange clicking noise randomly, which sounds rather like the indicator noise. At first, it was just in bursts after I'd indicated.. but this morning when I hopped in the car, it was doing it constantly. Turning the wipers on/off didn't do anything (I'd left them on rain-sensing, so I thought it worth a try), likewise indicating didn't stop it - while indicating, I could just hear the normal noise, indicator off and it went back to a faster rate of clicking.

    ARGH!

    And.. to top it off... the service-indicator has suddenly zero'd. It should have about 5000km to go (it's been counting down nicely) but this morning - 0!.

    So.. any thoughts on what might be causing this?

    Advertisement


    Thanks all,
    Dave.

  2. #2
    1000+ Posts CHRI'S16's Avatar
    Join Date
    Jun 2002
    Location
    Sydney
    Posts
    3,298

    Default

    ...ahhhh the indicator stalk clicking again rises its ugly head. One of the 306's trademark. Take the car to a good service center and explain your problem.
    Its not something i recommend as poking around there on a 306 could lead to an air-bag failure/setoff if you are not careull.
    How ever if you are VERY comfy and confident in you own ability then have ago at replacing the unit youself.
    Do a search (here on AF) as i know this topic has been around before. good luck-chris
    ... ptui!

  3. #3
    Fellow Frogger! J4RS's Avatar
    Join Date
    Jan 2004
    Location
    Sydney
    Posts
    178

    Default

    Quote Originally Posted by sysiphus
    Hiyas,

    Newbie question time again My 98 306 has just started making a strange clicking noise randomly, which sounds rather like the indicator noise. At first, it was just in bursts after I'd indicated.. but this morning when I hopped in the car, it was doing it constantly. Turning the wipers on/off didn't do anything (I'd left them on rain-sensing, so I thought it worth a try), likewise indicating didn't stop it - while indicating, I could just hear the normal noise, indicator off and it went back to a faster rate of clicking.

    ARGH!

    And.. to top it off... the service-indicator has suddenly zero'd. It should have about 5000km to go (it's been counting down nicely) but this morning - 0!.

    So.. any thoughts on what might be causing this?

    Thanks all,
    Dave.
    Hello,
    Your not alone... N3, N5's all have this problem from time to time.. The indicator stalk it's self is to blame... as advised by Chris16 taking the car to a dealer is the easy option and should set you back around $150... Get done sooner rather than later as I have seen melted dashes... (rare though!!)

    PS If you Really want to DIY Let me know I'll give you the part number and a guide to the method...

    Good luck..

  4. #4
    Member
    Join Date
    Nov 2003
    Posts
    59

    Default

    Thanks for the advice, everybody... guess it's just something to put on "the list" when I take this baby in for its first real service.


    *sigh*

    Thanks again

  5. #5
    Member
    Join Date
    Nov 2003
    Posts
    59

    Default

    Quote Originally Posted by J4RS
    Hello,
    Your not alone... N3, N5's all have this problem from time to time.. The indicator stalk it's self is to blame... as advised by Chris16 taking the car to a dealer is the easy option and should set you back around $150... Get done sooner rather than later as I have seen melted dashes... (rare though!!)
    In case anyone's interested, I haven't managed to get the relay fixed yet.. but as I was just driving home, a small plume of electrical smoke blossomed from my steering column.

    "Oh bother" says Dave, <small>as he calls his auto-leccy man to book the car in for Tuesday</small>

    *sigh*

    Guess I won't be driving the old girl this weekend

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •