79 504Ti black fuel and black injection fluid
  • Register
  • Help
Results 1 to 8 of 8
  1. #1
    Tadpole
    Join Date
    Aug 2012
    Location
    SunshineCoast
    Posts
    5

    Default 79 504Ti black fuel and black injection fluid

    Long time reader first time poster. I own a 79 504ti import which I got as a hand me down from my old man. Owned a 75GL for 11 years loved that car easy to keep running but the rust eventually had retired it. Sad.. This 504Ti now had for over year. But now this problem of oil I think of mixing with the red injection pump fluid then with the fuel turning the fluids to black. Has got me stumped. Is there any o ring seals inside the injection pump? And is there any special sockets needed.

    Advertisement

  2. #2
    1000+ Posts BIGRR's Avatar
    Join Date
    Feb 2006
    Location
    North Rocks, Sydney
    Posts
    2,446

    Default

    What fluids are black?
    Present fleet:-
    Peugeot 93' 205 Gti 16v
    Peugeot 73' 504 Ti from new
    Peugeot 08' 407 Hdi Coupe from new

    Previous fleet:-
    Peugeot 95' 605 Sv
    Peugeot 92' 205 Gti
    Renault 72' 16TS from new
    Renault 69' 10
    Renault 71' 10s
    Renault 68' 10 from new

    "Be reasonable do it my way!"


  3. #3
    Budding Architect ???? pugrambo's Avatar
    Join Date
    Jul 2000
    Location
    Parkes - N.S.W - Australia - Earth
    Posts
    12,269

    Default

    Quote Originally Posted by 504love View Post
    Long time reader first time poster. I own a 79 504ti import which I got as a hand me down from my old man. Owned a 75GL for 11 years loved that car easy to keep running but the rust eventually had retired it. Sad.. This 504Ti now had for over year. But now this problem of oil I think of mixing with the red injection pump fluid then with the fuel turning the fluids to black. Has got me stumped. Is there any o ring seals inside the injection pump? And is there any special sockets needed.
    if the pump oil was red it's the wrong oil to start with
    3 x '78 604 SL

    1 x 2018 3008

    1 x 2000 Citroen XM,

    1 x '98 306 GTi6 sadly sold

    1 x secret project

    1 x '98 406 STDT troop carrier and i don't care if it stinks, i don't sniff it's arse Death by wank tank

    1 x '99 406SV 5spd wagon, time to burn more fuel

    1 x 1994 605 SV3.0

  4. #4
    Fellow Frogger!
    Join Date
    Dec 2002
    Location
    CANBERRA
    Posts
    400

    Default

    It is common to run ATF, often red, in the pump.

    Engine oil flows through the pump body fed from the oil filter housing so maybe it can leak through to the vale body.

  5. #5
    Budding Architect ???? pugrambo's Avatar
    Join Date
    Jul 2000
    Location
    Parkes - N.S.W - Australia - Earth
    Posts
    12,269

    Default

    Quote Originally Posted by pug303 View Post
    It is common to run ATF, often red, in the pump.

    Engine oil flows through the pump body fed from the oil filter housing so maybe it can leak through to the vale body.
    it is common but it is the wrong oil

    castrol used to make an oil for the pumps, i'm sure looking through the available oils there would be a better 15 grade oil to use than ATF
    3 x '78 604 SL

    1 x 2018 3008

    1 x 2000 Citroen XM,

    1 x '98 306 GTi6 sadly sold

    1 x secret project

    1 x '98 406 STDT troop carrier and i don't care if it stinks, i don't sniff it's arse Death by wank tank

    1 x '99 406SV 5spd wagon, time to burn more fuel

    1 x 1994 605 SV3.0

  6. #6
    1000+ Posts BIGRR's Avatar
    Join Date
    Feb 2006
    Location
    North Rocks, Sydney
    Posts
    2,446

    Default

    Sewing Machine oil!!! (And that is just how my Ti runs).
    Present fleet:-
    Peugeot 93' 205 Gti 16v
    Peugeot 73' 504 Ti from new
    Peugeot 08' 407 Hdi Coupe from new

    Previous fleet:-
    Peugeot 95' 605 Sv
    Peugeot 92' 205 Gti
    Renault 72' 16TS from new
    Renault 69' 10
    Renault 71' 10s
    Renault 68' 10 from new

    "Be reasonable do it my way!"


  7. #7
    Tadpole
    Join Date
    Aug 2012
    Location
    SunshineCoast
    Posts
    5

    Default

    I got recommended power steering fluid sae 10w for in the box shaped injection pump body.The proper esso 10w don't know were to find it, even if it exists anymore. I'm wondering if the engine oil penrite 20w-60 is leaking into the injection pump box. There seems to be a lot of pressure inside the pump body there were always injection pump oil leaks from the red filler cap or from the delivery valves when I stopped those leaks and went on a road trip to victoria it seems the mixed oils pressure from the injection pump continued through to the fuel line contaminating the fuel making the Ti smoke and at the same time splitting a hole in the small injection pump diaphram making it run like a hairy goat and stalling on idle. The only way to get it to idle above 1000rpm was to completely remove the idle metering screw therefore sucking in unfiltered air. But that kept in car borderline drivable. In knowing that one of the injection pump diaphrams was split was that the only place that had a set of new big and small diaphrams was back home on the sunshine coast. Is the engine oil penrite 20w-60 too thick thereby making the engine oil pressure higher for the Ti so could be the root of the problem? I seem to have to top up the engine oil 1 litre every 320 miles. The speedo reads in mph even though its a 79Ti.

  8. #8
    Tadpole
    Join Date
    Aug 2012
    Location
    SunshineCoast
    Posts
    5

    Default

    79 504Ti black fuel and black injection fluid-_0015290.jpg79 504Ti black fuel and black injection fluid-_0015331.jpg79 504Ti black fuel and black injection fluid-_0015309.jpgGot it running again back to normal, yep the small pump diaphram did split. Changed the fuel filters they were black as. As for the problem with the contaminated fuel and pump fluid, I'm going back to 20w50 engine oil and loosen the red filler cap slightly on the pump body so maybe less pressure. I'll see what happens. I'm back to loven the Ti again.. Rest in peace dear old GL.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •