Non Froggy Weber **HELP**
  • Register
  • Help
Results 1 to 3 of 3
  1. #1
    1000+ Posts Pugnut403's Avatar
    Join Date
    Mar 2003
    Location
    Tasmania
    Posts
    1,419

    Non Froggy Weber **HELP**

    The Weber 34 ADM in the Transit is driving us crazy.
    Since day one it has been missing, backfiring, etc when the secind barrell starts to open. If you floor it it comes good after a few seconds, but flooring it with the 4.1 in a Transit is scary stuff.
    Now it will run crap if you try to drive at a steady speed. The only way to run OK is to floor it until you get to the speed you want and back off to hold that speed. This works for a minute or so until you need to adjust the speed slightly, when you have to floor it again.
    It is using SO much fuel at the same time, and when it is playing up you can smell the unburnt fuel being backfired out.
    It is driving us nuts!!!
    HELP!!!!

    Advertisement
    Pugs Rule!

    403, now sold
    404, project
    2010 Mitsubishi i MiEV electric car

  2. #2
    Guru davemcbean's Avatar
    Join Date
    Apr 2001
    Location
    Camden NSW & Selwyn NZ
    Posts
    2,333
    Was the Weber from an XE or XF Falcon?

    The XE version has a funny variably idle jet on the first throat with a hose going to it, while the later XF has a conventional idle jet and is supposedly a much more trouble free carb.

    Your problem sounds like something else. Maybe the secondary idle jet is blocked? This may give a lean condition as the second throat just starts to open, resulting in the symptoms you describe. Some Webers have an idle stop on the second throat and if this is not set right, you can also get those symptoms.

    If the problem occur just before the second throat starts to open, then maybe the primary main jet is slightly blocked, or just too lean for the engine. The XF version has a slightly richer primary main jet (140 as opposed to 135 or 137).

    Anyway, I hope what I've said helps a little.

    Dave
    NZ Fleet
    1976 504 Ti
    1984 205 GT twin carb
    1991 205 SI 1.6GTI motor
    1994 106 Xsi
    1996 Mondeo V6
    Aus Fleet
    1955 203C
    1997 Civic Cxi (great allrounder- revy, flexible, nimble, comfortable , economical, simple and durable )

  3. #3
    1000+ Posts Pugnut403's Avatar
    Join Date
    Mar 2003
    Location
    Tasmania
    Posts
    1,419
    The rough running all the time has been almost cured by putting a bottle of metho down the fuel tank, but the second choke trouble is still there.
    The carby is off an XE, and I have plugged a few hoses to get it running. I plan to get a workshop manual soon soI can work out where all of the hoses go to, but I have plugged a few for now. What does the jet hose go to?
    Pugs Rule!

    403, now sold
    404, project
    2010 Mitsubishi i MiEV electric car

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •