CX not rising
  • Register
  • Help
Results 1 to 6 of 6

Thread: CX not rising

  1. #1
    Fellow Frogger! salman's Avatar
    Join Date
    Jan 2005
    Location
    Melbourne Australie
    Posts
    192

    Default CX not rising

    This is a Prestige I restored 9 years ago,its overseas.Need some quick thoughts.
    It was parked for a long time,now on starting refused to rise.I adviced to clean reservoir and prime pump.He has done this but still no lifting.Its hard diagnosing from far away but any suggestions welcome.

    Advertisement

  2. #2
    1000+ Posts Ken W's Avatar
    Join Date
    Sep 2002
    Location
    North Brisbane
    Posts
    1,892

    Default

    Height lever is on low?

    Is it a late model one like a series 2? It might have a motorised height control like the Xantias that has got stuck?

    Need more info please.

    Cheers,

    Ken W

  3. #3
    Fellow Frogger! salman's Avatar
    Join Date
    Jan 2005
    Location
    Melbourne Australie
    Posts
    192

    Default early type

    Sorry should have mentioned its 1982,Petrol.

  4. #4
    Real cars have hydraulics DoubleChevron's Avatar
    Join Date
    May 2000
    Location
    Ballarat,Vic,Aust.
    Posts
    16,322

    Default

    It just wont have bleed. Tell them to try again. Sometimes there real [email protected] to bleed. They need to check the feed line for fine cracks in the suction hose, and the hose clamps too.

    seeya,
    Shane L.
    'Cit' homepage:
    Citroen Workshop
    Proper cars--
    '85 Series II CX2500 GTi Turbo I
    '63 ID19 http://www.aussiefrogs.com/forum/citro%EBn-forum/90325-best-project-car-you-have-ever-seen.html
    '72 DS21 ie 5spd pallas (last looked at ... about 15years ago)
    '78 GS1220 pallas
    '92 Range Rover Classic ... 5spd manual.

    Yay ... No Slugomatics


    Modern Junk:
    '07 Poogoe 407 HDi 6spd manual

  5. #5
    Tadpole
    Join Date
    Jan 2011
    Location
    Sydney
    Posts
    5

    Default

    When mine had this problem, also after sitting for a long time, it tuned out to be the priority/distribution valve.

    cheers,

    Martin

  6. #6
    Fellow Frogger
    Join Date
    Jan 2004
    Location
    Sydney
    Posts
    9,670

    Default

    Bleed valve on the regulator is open? Does the regulator cut in/out? Could the spheres be so flat, that it's filling them and pumping itself dry?

    The last time I encountered a hydraulic Citroen that refused to rise (unless revved quite hard), was a D Special with a crack in the pump body. It was leaking badly internally, so not creating pressure and also weeping out the front. The low pressure prevented the priority valve from supplying fluid to more than the brakes. I think the CX would be the same, so it should also not have steering assistance.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •